Video Streaming unavailable, even though it is enabled

Hello, I am trying to build a custom QGroundStation app through Qt Creator. I followed the instructions and documentation on installing and it builds and works fine. The only problem that I am encountering is that GStreaming is not working for some reason.

I see this message (emitted from VideoReceiver.pri) which suggests that GStreamer is found

Project MESSAGE: Including support for video streaming.

Which means that QGC_GST_STREAMING define should be enabled, but any code that checks for it like #ifdef QGC_GST_STREAMING is ignored.

As a result I do not have the option to use any of the gstreaming options like rtsp, udp, tcp etc.
Any help to enable the gstreaming is appreciated.

There isn’t much you need to do beyond installing gstreamer per the instructions for your OS. You’ll need to debug through the build process to figure out why the define isn’t working. What OS are you building for?

I’m building for Windows.

Curious thing is the code editor highlights the code like the define is enabled (its contents aren’t grayed-out), but the build just ignores any code that is inside the define.

Any debug message that I’m printing before the #ifdef shows as expected and anything inside does not show. Also the streaming options are missing in the app as I already mentioned.


I tried some random stuff like reinstalling packages (didn’t help), moving to a different branch, moving back to master, clearing everything etc and at one point it just worked. No idea what exactly fixed it.