Vibration Issue


I’m flying a large 28" propeller hexacopter and I’m getting high accelerometer and gyro noise:

The airframe is very stiff, including the arms. (this frame:

I have tried the usual things to reduce vibrations:

  1. I ran each of the motors individually (without props) to check if they are unbalanced and they run very smoothly. I also checked the balance of each prop and they are very well balanced. They are T-motor props and motors, which usually come balanced.
  2. I mounted the Pixhawk 2.1 using soft foam pads.

However the accelerations still seem high. Here are my questions:

  1. What is your judgement of the noise levels?
  2. Is this level of noise a safety concern?
  3. Do you recommend me playing with the filtering settings for the accelerometers and gyros?
  4. Is there anything else I can do?

Thank you!

1 Like

yep, those are fairly high looking vibration levels. If you want to do more research you might try the EKF2 Replay on some test data.

You are checking the right things. Vibration is often very tricky.

Another thing you can do is adjust your autopilot mounting strategy. You can try either stiffer or softer foam mounts. You might also try to “mass dampen” your autopilot by hard-mounting it to a heavy (relatively) plate and then vibration isolating that plate. If you make the mass of the whole autopilot larger its responses to vibration input should be attenuated.

Thank you very much for the tips. I will try attaching a mass to the FC to see if this reduces vibration. I’m also paying more attention to how the cables are attached to the FC, to try to minimize transfer of vibration. Let’s see if that helps.

In my case, after I changed PX4 firmware to V1.8.2 high vibration happened before takeoff. The vibration disappeared after the rate D gain of pitch and roll has been changed from 0.003 to 0.001.
The airframe is generic quad x. FCC is Pixhawk2.1. PX4 v1.8.2. All the parameters are default setting.

I have the same problem,

is there any way to set up the filtering of the gyros and accelerometers to solve this on the software level?

I imagine that high noise on the angular rates makes the derivative compensation completely inapplicable.

1 Like

as far as I know, the only parameter available to try to filter the accelerometers is IMU_ACCEL_CUTOFF that sets the cutoff frequency of a second order Butterworth filter (default is 30Hz). However, as described in the Parameter Reference section:

The cutoff frequency for the 2nd order butterworth filter on the accel driver. This only affects the signal sent to the controllers, not the estimators. 0 disables the filter.

I am not sure where the filtered values are actually being used. I am trying to investigate this further and I might update this answer in the next days.

Hey I’m Facing the same Issues.

I fly a 22 inch Propellor with a 300 KV motor. I’ve tried everything vibration dampers, Setting the filters right.

Dunno what else to do.