Trimble MB-Two not workin

I’m currently trying to integrate a Trimble MB-Two onto the pixhawk 4 to eventually do RTK DGPS, like this webpage discusses .
The Pixhawk 4 works normally and has a recent version of released 1.9 PX4 (configured as a coax octorotor). The stock holybro GPS/Mag works without a problem.
My MB-Two is an evaluation unit that has all the features required in that linked webpage. It has Rover and Base options enabled.
I unplugged the Holybro GPS and plugged in the TX1 RX1 lines from the Trimble into the GPS port as instructed in the webpage.
I don’t know what to setup the IO from the Trimble. I have tried many options.
I looked in the GPS driver code and surmise that it uses an ashtech protocol and uses the ZDA, GGA, HDT, POS, GST, GSV messages. So I set Port 1 to output those messages at 10Hz. However, even though the GPS is seeing plenty of satellites, the QGround control says go GPS Position.

When I go to the mavlink console and ask for GPS status. It says that GPS is not OK (at the correct 115200 baud) and displays a different protocol UBX, ASH, MKT etc for each status refresh.

Tried all manner of reboots, starts and stops.

@bkueng or @dagar , do you know what I’m doing wrong?

Hi @Ray_Gamero
Did you set the baudrate parameter?

Yes, I set it to 115200.

Hmm. Does it power up? Did you check if RX/TX are swapped?

Yes, The MB-Two is powered up and connected to a LAN so I can monitor that it it operating properly.
I verified, with an O-scope, that the outboound traffic (MB-Two pin 15/TX1 at 0-3v ) is plumbed to the GPS port pin 3 and the inbound traffic (pin 16 RX1) is plumbed to pin 2. Ground is also connected.
I have the Ground Station position using a UDP signal from another trimble.
I have attached a GPS status readout and a screenshot fo the MB-Two settings.