GPS over UART & I2C 2. (gps_2) (edit: pixhawk 4)

Ok, this thing Is driving me nuts.

Simply put, I have no Gps_2 parameters anywhere in Qgc with px4. And the “port assigning” described in the documentation does not apply at all.

I then flashed ardupilot witch ive used before, and sure enough there were an option for 2nd. Gps and it got lock, even tho no satellite count appeared.

Flashed back to px4 then px4 beta, still no sign of it. Seems I can change telem2 m, but not to gps.

My GPS module only has the 6pin connector (ts100 GPS).

Any help appreciated! I knew I had to get back in to Linux and compiling a firmware at some point, but only to change the I/O?

Hm, ok let’s try to debug this.

Are you following this guide?
And if it doesn’t work, where exactly?

ok, so i’m back at the computer now, give me a couple minutes and i will reproduce the results.

so heres with ardupilot.

i can set 2nd gps, and it will find the port itself, but notice no gps sat count even tho it has lock.

brb with the PX4 one.

and here’s from PX4, i have tried other search terms etc… even tried to download parameters as file, and adding gps_2 params.

am i locked at compiling it myself? if so, anyone willing to make a $ :joy: ?

the GPS module itself shows it has some sat connection at least, with both ardupilot and px4.

i really wanted to make the jump to px4 for this project. but i may have to run ardupilot for the demo of the rover if i can’t get this fixed as i’m kind of limited time wise atm.

so any help to get this sortet would be appreciated.

Anyone? :hugs:

PS. Anyone know where I can buy the GPS connector for the pixhawk 4? So I could splice the GPS to it, worst case.

You could try to open mavlink_shell ( and set the param there using param set GPS_2_CONFIG 202.

Also, I just had a thought. Which PX4 version are you using? This configuration is only available with master and not with stable (1.8.2) yet.

Sorry I haven’t gotten back to the topic as I’ve been offline.

But thanks a lot Julian!

I went to master(to look at the option you provided), long behold it has the second gps setting.

I feel a little dumb for not figuring it out.
Everyday is a learning day :slight_smile:

1 Like

Nice, glad you could resolve it.