Timeout and strange movement when trying to connect gimbal via PWM

I’m trying to connect a Tarot TL3T05 gimbal to a Pixhawk 4 .I only need to control the pitch, so I connected the PWM pitch input of the gimbal to the first and last pin of “FMU PWM OUT”. In PX4, I set the MNT_ parameters accordingly. See my full parameter list here.
Also, a Raspberry 4 is connected as companion computer via TELEM.

Now I got 2 problems:

  1. For some reason, the gimbal always tries to pitch down when connected.

  2. For testing a gimbal, I usually run the MAVSDK gimbal example, substituting the SITL system address (udp://:14540) with mine (serial:///dev/serial0:921600).
    Running the example produces the following error message:

Traceback (most recent call last):
File “gimbal.py”, line 61, in
File “/usr/lib/python3.7/asyncio/runners.py”, line 43, in run
return loop.run_until_complete(main)
File “/usr/lib/python3.7/asyncio/base_events.py”, line 584, in run_until_complete
return future.result()
File “gimbal.py”, line 23, in run
await drone.gimbal.set_mode(GimbalMode.YAW_FOLLOW)
File “/home/pi/venv_mission/lib/python3.7/site-packages/mavsdk/gimbal.py”, line 484, in set_mode
raise GimbalError(result, “set_mode()”, gimbal_mode)
mavsdk.gimbal.GimbalError: TIMEOUT: ‘Timeout’; origin: set_mode(); params: (<GimbalMode.YAW_FOLLOW: 0>,)

This gimbal was already successfully connected to a Pixhawk 6c, so it should be working.

The timeout problem seems to be vanished. Unfortunately, I have no idea why.
My RPi has an LTE-module, which couldn’t connect, because I left the antennas off. When I booted with the antennas on, the LTE connection was properly initialized and from that moment on, the gimbal started working. Don’t know if there is any relation, but that is all I can say…

As for the gimbal aiming down: The values PWM_AUX_MIN and PWM_AUX_MAX set the minimum and maximum pulse width that can be send to the gimbal. When you send a tilt value in degrees, this value is mapped to the corresponding pulse width between _MIN and _MAX. These PWM values are different for various models and often, you have to play with them until you find the right setting (Unless the producer tells you). Mine was 1100-1900.