"Timed out waiting for erase"

I am constantly modifying the firmware with my own fixed-wing flight controller module, and recently I started running into an error when I try to upload the firmware. It happens either in the “Erase” or “Program” step. It’s not correlated with my changes to the firmware, because sometimes I can try uploading again after failing and have the upload work successfully.

I’m curious, could this issue have anything to do with the MicroSD card? I ask because last time I flew I encountered this issue, eventually uploaded the firmware, and then the Pixhawk was making the sounds it makes when it doesn’t have an SD card inserted (which it did). And it turns out that after this happened, the Pixhawk stopped logging my flight data.

I’ve seen the timeout a couple of times myself too. I just tried a second time and everything worked fine. So probably nothing to worry about.

The SD card issue is most likely unrelated. I suggest you try formatting it or using a different one.