The interfaces of gazebo are different when making the same command

Hi, I am sorry for stupid question, but I am new in the field.

When I make the command make px4_sitl gazebo-classic_iris , most of the time the interface of gazebo like this, the models and lights on the left column have nothing and I can’t add box in this world. But the iris can takeoff and land when I make the commander in the terminal.

But in few times, the models and lights on the left column have the models and I can modify the world.

I don’t know why and how to solve it.

I use the gazebo 11 and the latest px4.

I see the same. It happens to me maybe 1 in 10 times, and I just have to try again. I suspect it’s a Gazebo bug, or caused by a bug in one of the Gazebo plugins.

Thanks for your reply. It happens to me maybe 9 in 10 times. I want to add a lidar and get the data to build map. But I do nothing until it is solved, it is so frustrating.

Does it go away when you stash your changes? If so, it might be something wrong with the added/enabled code.

Actually, I re-install the PX4 and run the iris and standard_vtol. It still exist. The below is the output code:

make px4_sitl_default gazebo-classic_iris
[0/4] Performing build step for 'sitl_gazebo-classic'
ninja: no work to do.
[3/4] cd /home/a/PX4/PX4-Autopilot/bui...4/PX4-Autopilot/build/px4_sitl_default
sitl_bin: /home/a/PX4/PX4-Autopilot/build/px4_sitl_default/bin/px4
debugger: none
model: iris
world: none
src_path: /home/a/PX4/PX4-Autopilot
build_path: /home/a/PX4/PX4-Autopilot/build/px4_sitl_default
GAZEBO_PLUGIN_PATH :/home/a/PX4/PX4-Autopilot/build/px4_sitl_default/build_gazebo-classic
GAZEBO_MODEL_PATH :/home/a/PX4/PX4-Autopilot/Tools/simulation/gazebo-classic/sitl_gazebo-classic/models
LD_LIBRARY_PATH /usr/lib/x86_64-linux-gnu/gazebo-11/plugins:/opt/ros/foxy/opt/yaml_cpp_vendor/lib:/opt/ros/foxy/opt/rviz_ogre_vendor/lib:/opt/ros/foxy/lib/x86_64-linux-gnu:/opt/ros/foxy/lib:/home/a/PX4/PX4-Autopilot/build/px4_sitl_default/build_gazebo-classic
empty world, setting as default
Using: /home/a/PX4/PX4-Autopilot/Tools/simulation/gazebo-classic/sitl_gazebo-classic/models/iris/iris.sdf
Warning [] XML Attribute[version] in element[sdf] not defined in SDF, ignoring.
SITL COMMAND: "/home/a/PX4/PX4-Autopilot/build/px4_sitl_default/bin/px4" "/home/a/PX4/PX4-Autopilot/build/px4_sitl_default"/etc

______  __   __    ___ 
| ___ \ \ \ / /   /   |
| |_/ /  \ V /   / /| |
|  __/   /   \  / /_| |
| |     / /^\ \ \___  |
\_|     \/   \/     |_/

px4 starting.

INFO  [px4] startup script: /bin/sh etc/init.d-posix/rcS 0
INFO  [init] found model autostart file as SYS_AUTOSTART=10015
INFO  [param] selected parameter default file parameters.bson
INFO  [param] importing from 'parameters.bson'
INFO  [parameters] BSON document size 316 bytes, decoded 316 bytes (INT32:13, FLOAT:3)
INFO  [param] selected parameter backup file parameters_backup.bson
INFO  [dataman] data manager file './dataman' size is 7866640 bytes
etc/init.d-posix/rcS: 39: [: Illegal number: 
INFO  [init] PX4_SIM_HOSTNAME: localhost
INFO  [simulator_mavlink] Waiting for simulator to accept connection on TCP port 4560
INFO  [simulator_mavlink] Simulator connected on TCP port 4560.
INFO  [lockstep_scheduler] setting initial absolute time to 3436000 us
INFO  [commander] LED: open /dev/led0 failed (22)
WARN  [health_and_arming_checks] Preflight Fail: ekf2 missing data
Gazebo multi-robot simulator, version 11.13.0
Copyright (C) 2012 Open Source Robotics Foundation.
Released under the Apache 2 License.

[Msg] Waiting for master.
[Msg] Connected to gazebo master @
[Msg] Publicized address:
INFO  [mavlink] mode: Normal, data rate: 4000000 B/s on udp port 18570 remote port 14550
INFO  [mavlink] mode: Onboard, data rate: 4000000 B/s on udp port 14580 remote port 14540
INFO  [mavlink] mode: Onboard, data rate: 4000 B/s on udp port 14280 remote port 14030
INFO  [mavlink] mode: Gimbal, data rate: 400000 B/s on udp port 13030 remote port 13280
INFO  [logger] logger started (mode=all)
INFO  [logger] Start file log (type: full)
INFO  [logger] [logger] ./log/2023-06-17/01_14_21.ulg	
INFO  [logger] Opened full log file: ./log/2023-06-17/01_14_21.ulg
INFO  [mavlink] MAVLink only on localhost (set param MAV_{i}_BROADCAST = 1 to enable network)
INFO  [mavlink] MAVLink only on localhost (set param MAV_{i}_BROADCAST = 1 to enable network)
INFO  [px4] Startup script returned successfully
pxh> INFO  [tone_alarm] home set
INFO  [tone_alarm] notify negative
INFO  [commander] Ready for takeoff!

Not sure if this is the problem?

This also doesn’t look right.

Oh, try setting export VERBOSE_SIM=1 and check if you get more output!

Thanks for you help. I have solved this question by changing a better computer. :joy:

Alright. I wonder what the issue was though.

Maybe the low-end computers cannot run the gazebo well.