[Err] [gazebo_mavlink_interface.cpp:238] real_time_update_rate is set to 500 instead of 250, aborting. in Gazebo SITL

#1

I tried to run a SITL simulaiton but errors occurred.
Here’s the log.

kumaron@ubuntu:~/px4/v1.8.2/Firmware$ make posix_sitl_default gazebo
ninja: Entering directory `/home/kumaron/px4/v1.8.2/Firmware/build/posix_sitl_default'
[3/7] Performing configure step for 'sitl_gazebo'
-- install-prefix: /usr/local
-- Boost version: 1.58.0
-- Found the following Boost libraries:
--   system
--   thread
--   timer
--   chrono
--   date_time
--   atomic
-- Boost version: 1.58.0
-- Building klt_feature_tracker without catkin
-- Building OpticalFlow with OpenCV
-- catkin DISABLED
Gazebo version: 7.14
-- Using C++17 compiler
-- Configuring done
-- Generating done
-- Build files have been written to: /home/kumaron/px4/v1.8.2/Firmware/build/posix_sitl_default/build_gazebo
[4/7] Performing build step for 'sitl_gazebo'
ninja: no work to do.
[7/7] cd /home/kumaron/px4/v1.8.2/Firm....8.2/Firmware/build/posix_sitl_default
args: /home/kumaron/px4/v1.8.2/Firmware/build/posix_sitl_default/px4 posix-configs/SITL/init/ekf2 none gazebo none /home/kumaron/px4/v1.8.2/Firmware /home/kumaron/px4/v1.8.2/Firmware/build/posix_sitl_default
SITL ARGS
sitl_bin: /home/kumaron/px4/v1.8.2/Firmware/build/posix_sitl_default/px4
rcS_dir: posix-configs/SITL/init/ekf2
debugger: none
program: gazebo
model: none
src_path: /home/kumaron/px4/v1.8.2/Firmware
build_path: /home/kumaron/px4/v1.8.2/Firmware/build/posix_sitl_default
empty model, setting iris as default
GAZEBO_PLUGIN_PATH :/home/kumaron/px4/master/Firmware/build/px4_sitl_default/build_gazebo:/home/kumaron/px4/v1.8.2/Firmware/build/posix_sitl_default/build_gazebo
GAZEBO_MODEL_PATH :/home/kumaron/px4/master/Firmware/Tools/sitl_gazebo/models:/home/kumaron/catkin_ws/src/avoidance/sim/models:/home/kumaron/px4/v1.8.2/Firmware/Tools/sitl_gazebo/models
LD_LIBRARY_PATH /home/kumaron/catkin_ws/devel/lib:/opt/ros/kinetic/lib:/opt/ros/kinetic/lib/x86_64-linux-gnu:/home/kumaron/px4/master/Firmware/build/px4_sitl_default/build_gazebo:/home/kumaron/px4/v1.8.2/Firmware/build/posix_sitl_default/build_gazebo
Gazebo multi-robot simulator, version 7.14.0
Copyright (C) 2012 Open Source Robotics Foundation.
Released under the Apache 2 License.
http://gazebosim.org

[Msg] Waiting for master.
[Msg] Connected to gazebo master @ http://127.0.0.1:11345
[Msg] Publicized address: 192.168.8.105
[Dbg] [gazebo_mavlink_interface.cpp:137] <joint_name> not found for channel[0] no joint control will be performed for this channel.
[Dbg] [gazebo_mavlink_interface.cpp:137] <joint_name> not found for channel[1] no joint control will be performed for this channel.
[Dbg] [gazebo_mavlink_interface.cpp:137] <joint_name> not found for channel[2] no joint control will be performed for this channel.
[Dbg] [gazebo_mavlink_interface.cpp:137] <joint_name> not found for channel[3] no joint control will be performed for this channel.
[Wrn] [gazebo_mavlink_interface.cpp:126] joint [zephyr_delta_wing::propeller_joint] not found for channel[4] no joint control for this channel.
[Wrn] [gazebo_mavlink_interface.cpp:126] joint [zephyr_delta_wing::flap_left_joint] not found for channel[5] no joint control for this channel.
[Wrn] [gazebo_mavlink_interface.cpp:126] joint [zephyr_delta_wing::flap_right_joint] not found for channel[6] no joint control for this channel.
[Dbg] [gazebo_mavlink_interface.cpp:137] <joint_name> not found for channel[7] no joint control will be performed for this channel.
[Msg] Conecting to PX4 SITL using TCP
[Msg] Lockstep is enabled
[Msg] Speed factor set to: 1
[Err] [gazebo_mavlink_interface.cpp:238] real_time_update_rate is set to 500 instead of 250, aborting.
SITL COMMAND: /home/kumaron/px4/v1.8.2/Firmware/build/posix_sitl_default/px4 /home/kumaron/px4/v1.8.2/Firmware /home/kumaron/px4/v1.8.2/Firmware/posix-configs/SITL/init/ekf2/iris
data path: /home/kumaron/px4/v1.8.2/Firmware
commands file: /home/kumaron/px4/v1.8.2/Firmware/posix-configs/SITL/init/ekf2/iris
276 WARNING: setRealtimeSched failed (not run as root?)

______  __   __    ___ 
| ___ \ \ \ / /   /   |
| |_/ /  \ V /   / /| |
|  __/   /   \  / /_| |
| |     / /^\ \ \___  |
\_|     \/   \/     |_/

px4 starting.

Gazebo multi-robot simulator, version 7.14.0
Copyright (C) 2012 Open Source Robotics Foundation.
Released under the Apache 2 License.
http://gazebosim.org

[Msg] Waiting for master.
INFO  [dataman] Unknown restart, data manager file 'rootfs/fs/microsd/dataman' size is 11405132 bytes
INFO  [simulator] Waiting for initial data on UDP port 14560. Please start the flight simulator to proceed..
[Err] [Connection.cc:542] Connection[0] Closed during Read
[Err] [ConnectionManager.cc:141] Unable to read from master
[Err] [gazebo_shared.cc:83] Unable to initialize transport.
[Err] [gazebo_client.cc:62] Unable to setup Gazebo
^C
Exiting...
pxh> Shutting down
Restoring terminal
/home/kumaron/px4/v1.8.2/Firmware/Tools/sitl_run.sh: line 160: 23656 Aborted                 (core dumped) gzserver --verbose ${src_path}/Tools/sitl_gazebo/worlds/${model}.world
/home/kumaron/px4/v1.8.2/Firmware/Tools/sitl_run.sh: line 170: kill: (23656) - No such process
/home/kumaron/px4/v1.8.2/Firmware/Tools/sitl_run.sh: line 172: kill: (23678) - No such process
ninja: build stopped: interrupted by user.
Makefile:148: recipe for target 'posix_sitl_default' failed
make: *** [posix_sitl_default] Error 2

I googled but didn’t find any solutions.
How can I solve this?

#2

I assume you’re using a custom world file?

Make sure you have these params set like this for the world you’re using:

#3

@JulianOes Yes, I reset the params and successfully ran the simulation. Thank you for your help.

1 Like