Telemetry with RFD modem invisible on Q ground control

Hello !

I am trying to implement telemetry with my Pixhawk 2.

I have 2 RFD 868+ modem, one is connected to my computer with an FTDI cable. And the other to my Pixhawk. There are connected together because the green light is solid. I have download the driver for the FTDI cable and update the firmware of the each modem.

However I can’t connect the Pixhawk on Q ground control.

Is there a parameter to change on the Pixhawk to able the telemetry ?Is there a way to see if the Pixhawk communicate with my modem ?

Thank you

I have finally solved my problem. I had 3 mistakes :

-First one is a debutant mistake. I use a custom cable to link my modem to my pixhawk. And I link tx with tx and Rx with Rx instead of inversing each pins.

-second one, I did not link the ground of my pixhawk with the ground of the alimentation of my modem (I use another alimentation as it is advised to).

  • Finally my ftdi cable didn’t work when I linked tx and Rx together. So I take a new one and it work.