Storm32 and px4 flight stack

hi all

It’s known that ArduPlane frame stack has support for gimball control. There the sequence of actions for setup strorm32 with ArduPlane flight stack is described. As you can see, arduplane firmware has several parameters for setup gimbal connection and controlling. Does PX4 flight stack has such or similar parameters?

PX4 has support for Mavlink gimbals (, it’s just not as easy to access, or documented. We’re hoping to improve that soon.

hi, any basic step by step guide available somewhere? if I can find some inputs I will be able to help for documentation. Currently I try to configure a 3 axis Tarot Gimbal and a storm32. All input is welcome.

hi @chris66 what have you tried so far? Are you able to connect to the storm32 via serial and send mavlink commands?

hi @dagar, at this time nothing. I fligh with one drone setup with Ardupilot with a Tarot 3D gimbal, and now setting up a new drone with Px4 and a Storm32 gimbal. I use a Pixracer, this is why I want to use Px4 firmware now, gave up trying to configure compass with Ardupilot… so better results with Px4!

Okay, please get setup and we can work through getting it fully support.
I’ve only used these briefly, but it seems to me the best connection is serial and sending mavlink commands, but I think that’ll depend on the exact controller you have. Otherwise you could pass through a PWM for each axis you want to manually control. It really depends how you want to use the thing.
I’m dagar on PX4 slack if you’d like to discuss in real time (

thanks, good news, I will do that.

it’s nice news and is there any documentation about process of gimbal setup?

Gimbal setup -

Hi @dagar i have tried the same but with no luck
I am using raspberrypi on pixhawk telem 2 port and serial4/5 is connected to serial of storm 32 gimbal
mnt_in is set to 2 and mnt_out is set to 1
gimbal is not rotating as per the script.
please help us out.

@dagar thanks, I’ve just configurated to latest firmware 0.96. Set Mavlink config to Emit Heartbit and will try your configuration. Anyway, thanks for the time. Will give you my feedback asap.

1 Like

I am using 0.90 to emit heartbeat ,setup is working in ardupilot but no luck with px4
could anyone help?

@Mridul_Babbar did you try SYS_COMPANION with the baudrate configured to match? To use serial4/5 you’ll need to manually start mavlink.

i used 921600 companion link with 57600 i got timeout error
how to start mavlink manually? @dagar

Did you connect it to telem 2? What’s the storm32 baudrate?

i have connected to serial4/5 port and storm32 baud rate is 115200.

raspberry pi is connected to telem 2.


serial 4/5 has no mavlink instance running and is occupied by frSky telemtry in pixracer . Try to disable frsky process in startup script, and start another mavlink instance for it.

Thanks @rolandash for reverting!
i am using normal pixhawk fmuv2 version.
I tried connecting raspberry pi to telem 1 and and gimbal through serial on telem 2.
but mavlink commands are not working still.
gimbal emitting heartbeat @57600.
telem 2 is set to normal telemetry 57600

I did open a new topic a few days ago and today I found this one. My general question: are you able to control your gimbal manualy using UART gimbal to serial4/5 connection ? Is the someone who can control manualy gimbal using qground control and px4 firmware?
I know topic is old but maybe someone can help me.