Gimbal not working with Ground Control Stations

#1

My company have bought this gimbal:
https://www.foxtechfpv.com/foxtech-seeker-30-hd-30x-optical-zoom-camera-with-3-axis-gimbal.html#yt_tab_products1

I am having hard time to communicate it with Pixhawk Cube.

Gibal is not supporting MAVLink protocol. It is commanded with VISCA and PELCO protocol commands on serial connection (both with USB2TTL adapter and pixhawk serial port by using vehicle.message_factory.serial_control_encode() method of dronekit-python)

However I cannot make gimbal and camera work with QGroundControl, APM Planner2 or vehicle.gimbal commands with dronekit-python.

Currently trying with ArduPilot flight stack but i can change it to PX4 if necessary. I have tried Storm32 Gimbal Serial / Storm32 Gimbal MAVLink / Alexmos Serial gimbal parameter options but cannot see the gimbal.

Does anyone know about the gimbal that we’ve bought? Can it be used with ground control stations without changing source codes of GCS or autopilot or should i implement my own solution by using serial commands?

If i buy a gimbal controller like Storm32 or Alexmos can I use it with my gimbal and does it work with a GCS?

I’ve searched a lot and couldn’t find anything. Any help is much apprecited.

#2

I’ve no idea about PX4 support for those protocols: I don’t think they’re supported, but if they are that’s going to be the quickest path.
For ArduPilot, a visca camera driver is being worked on (https://github.com/ArduPilot/ardupilot/pull/8814), but not Pelco. You’d need to write a Pelco serial driver, or use an arduino/teensy as a PWM->Pelco converter (simplest). It’s a common enough protocol that there’ll be open source code somewhere.
You could use dronekit or mavros, but unless you have a companion computer already, it’s not an efficient way to do this.