Signal voltage low from i/o and FMU port of Pixhawk 4


I am currently new to the holybro Pixhawk 4 flight controller, and I have followed all the steps to assemble the flight controller and its components (PM board, telemetry, GPS module Flysky ppm receiver and 3S lipo battery) to my octacopter setup (T motors AT2317 880KV, Flame 40A esc and 1045 Propellers). My issues is that the motors do not run even when I successfully arm the system . I checked and pwm output from a digital multi meter and there is no signal coming from either the i/o port or FMU port, all I get is a constant noise of 1.2V from the i/o signal pins and 3.2V from the FMU ports. I tried all combinations of using the PM i/o and FMU ports but still get the same noise signals. I even tried the mavlink console using the commands,

pwm arm
pwm test -d /dev/pwm_output0 -a -p 1500

there were still no changes to the pwm signal outputs. I dont know what im doing wrong and it would be helpful if i could get some assistance on the same. I have attached a photo regarding this as well. Thankyou for your time and consideration.


The top pin should be signal it does not look like that is where your probe is connected.

1.18 V is seems normal that what I see on mine. and mine flys fine. it’s connected to the I/O PMW out CH1

FWIW This is a scope trace of the signal. It makes sense that it reads 1.2 V since it is 3.3 V at less that 50% duty cycle.