Pixhawk4 board (Output to M1 isn't working)

Hi! Im having some really weird issues with a Pixhawk4 board (Output to M1 isn’t working), I would appreciate any help:

Wiring (FMU-PWM-OUT -> FMU-PWM-IN, IO-PWM-OUT -> IO-PWM-IN)
Pixhawk 4 w/ px4 (tried with Ardupilot as well)
Pmo7 pwr management board
Airframe type (quad delta Vtol)
Hooked up motors M1 - M4 to ESCs with motors (swapped ESCs around they are all functional)
Outputs M2-M4 work fine but M1 can’t seem to connect to the esc (constant beeping)

Trouble Shooting steps:

  • Reinstalled airframe reference / swapped to other airframes (any referenece with motors port 2-8 work fine, just port 1 doesnt)
  • Reinstalled px4, tried different versions, tried Ardupilot as well
    -Replaced PMO7 pwr management board twice (had spares) same issue

My Thoughts
If there isn’t an obvious solution I think that port might be dead (Which ever IO output from the Pixhawk 4 that maps to M1 on the PMO7). Sadly I can’t currently afford a replacement Pixhawk 4, so how would I go about editing the airframe reference to swap M1 to M5 (or any of the others).

Update: I remapped the m1 output to port 5 and that seems to work fine.
pretty much “set PWM_OUT 1234” to “set PWM_OUT 5234” from https://github.com/PX4/PX4-Autopilot/blob/master/ROMFS/px4fmu_common/init.d/airframes/13006_vtol_standard_delta) and then uploaded