Separating Gazebo and PX4


I was facing some problems when I was trying to separate my gazebo model and PX4.

I built the gazebo model in a separate workspace (with all plugins, like imu, MAVLINK interface). After launching this model, it works well. But if I use the command “roslaunch px4 px4.launch” under my PX4 workspace, it shows waiting for TCP4560. (I do sure I TCP port works fine in my model).

Does anyone know how to fix my problem? Any suggestions are welcome!


Had this issue the other day from my mac dev computer.The only way I could get this to work after going through everything backwards and forwards was reinstalling the entire toolchain.

If you open gzserver in verbose mode it may give you some insightful info but even then, I ended up clearing the entire toolchain out which fixed it (which was annoying) but I had the same message. Verbose mode showed a little more as to what was going on but it was faster to simply redo the toolchain.

1 Like

Thanks a lot!!!

I solved my problem by git checkout the new PX4 SITL branch (at the branch of debug_mavlink).

Because the newest version required MAVLINK2.0 and the version before the branch of debug_mavlink doesn’t use TCP port communication.