PX4 silt on RPI and Gazebo simulator running on another PC in lan

Good morning,
I am trying a new algorithm for formation control.
My architecture is made by 2 raspberry PI3 running a simulation of PX4 SILT using this command:

no_sim=1 make px4_sitl_default none

This works and the simulator waits for a TCP connection on the port 4560.

A PC connected in the same lan of RPis, runs the gazebo simulation:

roslaunch gazebo_ros empty_world.launch world_name:=$(pwd)/Tools/sitl_gazebo/worlds/iris.world

The problem is that I am not understanding properly how to configure gazebo simulator such that it connects to the RPis.
I also gave a look to the launch files in Tools/launch, for instance in multi_uav_mavros_silt it has a parameter called fcu_url, i tried to set it, but the simulator is not connecting to the px4 simulation in RPi.

Could you please tell me where I can find a resource to learn how to do this configuration?
Thanks

@Satish1989221 Why do you need to run SITL and run the software on the rpi3? Why not just ron everything on the host system?

The next step will be using a px4 hardware in HILT mode attached to the RPi.
So, the simulator will be on the PC using MAVROS and Gazebo, the px4 hardware will be attached to the RPi in UART and RPi will run the formation control algorithm as companion cumputer.
I would go be step, but if you can help me to understand how to connect gazebo to a remote px4 using mavros/mavlink it would be really helpfull.

I tried something new, but without success.
Could someone tell me what I am missing?

So I compiled on the raspberry doing this:
export MAV_BROADCAST=1
make px4_silt_default none

And it compile and run waiting for a connection on the port 4560.

Then on the pc side:

DONT_RUN=1 make px4_sitl_default gazebo

then I changed the parameter in the file Tools/sitl_gazebo/models/iris/iris.sdf putting mavlink_addr same as the RPi’s ip.
then:

source Tools/setup_gazebo.bash $(pwd) $(pwd)/build/px4_sitl_default
gazebo Tools/sitl_gazebo/worlds/iris.world

But still gazebo is not connecting with the RPi. This works if the px4 simulation is in the pc.
How i could solve?

@JulianOes Maybe you could help us