Rover Airframe: APM: PREFLIGHT FAIL: AIRSPEED SENSOR MISSING

Hi guys,

I have put together a Wild Thumper 6WD Chassis equipped with Pixhawk2, raspberry pi 3, etc…

On QGroundControl I selected the Traxxas airframe and proceeded to do the sensor calibration.
My initial goal is to be able to drive the rover indoors using RC (which I have managed to do with the
ArduPilot flight stack).

My problem is that I am unable to arm. At initialisation I see get the following output:

MANUAL> Mode MANUAL
APM: PREFLIGHT FAIL: AIRSPEED SENSOR MISSING
APM: PREFLIGHT FAIL: EKF NOT USING GPS
APM: NOT ARMING: Preflight checks failed

I do not understand why AIRSPEED sensor is considered required for the rover. Also the GNSS keeps
flashing red.

Any suggestions or help regarding the steps to take to be able to drive rover indoors using
RC would be great.

Thanks a lot,

Guillaume

I managed to control the rover through RC, two things I had to do:

COM_ARM_WO_GPS Enabled Allow arming without GPS
CBRK_AIRSPD_CHECK 162128

The last one disables the airspeed check.

It’s still early for PX4 rover support. If you open a github issue and tag me I’ll look at having the airspeed ignored properly for ground rovers.

@dagar thanks. I have opened an issue on github.

On a separate note, I am seeking to autonomously control my rover indoors (no gps). As I am recently starting out with the px4 firmeware code base, I thought to make a copy of nuttx_px3fmu-v4_default.cmake and remove modules which would not be needed for the rover.

For instance, vtol_att_control etc… then proceed to write a flight stack which does not require GPS.
I was thinking of incorportating px4-companion architecture in which the PX4 client would simply listen to torque commands given by the companion computer. The companion computer would also take care of publishing the info over ros. In this way the control logic can be kept separate from the board whilst maintaining a high frequency of communication.