RKT GPS Sampling Rate Increasing

Hi team,
I am using a Holybro F9P RKT (using u-box) setup for one of my drones.

The default update rate of RTK is 1Hz. Since PX4 will automatically config u-box RKT and make the sampling rate to be maximum (ideal). However, I found that the GPS data from the logger was still 1Hz without any increase.

This F9P can easily go to 5Hz, and I can test it via u-center and it works well. So, I tried to change the sampling rate in the u-center, but it seems PX4 will rewrite my configuration by its default which is quite annoying. In this case, can you please advise how to stop PX4’s auto rewriting or could I change PX4’s default settings in order to increase the GPS sampling rate?

Many thanks.