RC/PWM Reverse Servo Setup unsuccessful T-REX 250

#1

I am facing weird issues. I am trying out different scenarios to get this to work but so far my results are far from safe, which is frustrating. Here are some of my experimental observations:

Channel 1 =Motor
Channel 2 =Elevator (PWM Reverse)
Channel 3 =Aileron
Channel 4=Pitch (PWM Reverse)
Channel 5=Rudder

Observation: Opposite Pitch Stabilization. Pitch RC Control OK. Roll Control opposed. Roll Stabilization OK.

Channel 1 =Motor
Channel 2 =Elevator
Channel 3 =Aileron (PWM Reverse)
Channel 4=Pitch
Channel 5=Rudder

Observation: Directions confirmed. Roll stabilization reversed…

Channel 1 =Motor
Channel 2 =Elevator (RC Reverse)
Channel 3 =Aileron
Channel 4=Pitch (PWM Reverse)
Channel 5=Rudder

Observation: Roll, Pitch & Yaw Stabilization confirmed. Elevator and roll control Reversed.

I can not seem to find a balance where my helicopter will stabilize and have correct actuation by RC. I have a feeling it might be because I am using Blade 130x Airframe setup on a T-REX250. The differences are that the elevator servo is at the back instead of the front. Maybe an issue with the mixer? Do you have any suggestions?

Regards, Junaid.

#2

Hello @Junaid ,
I think you are right, the mixer you are using is incorrect for your servo configuration. From PixRacer with T-Rex 250 Tail Lock I see that you are using a 0-120-240 configuration. In your case, if you have the elevator servo at the back, it should be 60-180-300.

Good luck!