Raspberry Pi not starting when connected with PixHawk


RPi = Raspberry Pi 4 Model B
PixHawk = PixHawk 4
Firmware = PX4 - 1.11.3
Baudrate = 921600
PixHawk Port = Telemetry 2
RPi Port = GPIO14, GPIO15
RPi OS = Ubuntu 20.04.04

I am getting an issue while trying to start the RPi while connected with the PixHawk.
Some invalid characters starts coming up on the screen. Screenshot is attached.

What I tried?
1- If I disconnect RPi from PixHawk & start both separately, then after both things bootup everything works fine. I can use mavros/mavlink to arm/disarm the drone (Heartbeat is coming ok).
2- I tried disconnecting all the peripherals except the telemetry/serial wire. Not worked.

RPi connection with PixHawk
Raspberry Pi is connected with PixHawk via serial connection (Telemetry 2 @ 921600).

Power to RPi
RPi is powered ON by connecting the power adapter (Micro USB) to the power port.

The following peripheral are connected with RPi:

  • LCD at HDMI port
  • Keyboard
  • Mouse
  • Ethernet Cable
  • Micro USB Cable (Power)