Problems connecting a Pixhawk 6c to a Raspberry Pi

I’m currently trying to connect a Pixhawk 6c (PX4) to a Raspberry Pi 4b. Similar problems were reported here. If I’m not making a basic mistake here, there might be a problem with 6c and companion computers.

I’ve connected the TELEM2 port to the RPi as follows:

  • 2 (UART5_TX) to GPIO15 (UART RX)
  • 3 (UART5_RX) to GPIO14 (UART TX)
  • 6 (GND) to a GND pin on the RPi

The relevant settings (=the settings which I consider relevant, feel free to ask for more):

MAV_1_FLOW_CTRL	Auto-detected
MAV_1_FORWARD		Disabled
MAV_1_MODE		Onboard
MAV_1_RATE		0 B/s
SER_TEL2_BAUD		921600 8N1

On the RPi side, I have edited the file /boot/config.txt and added the following lines under [all]


I furthermore disabled the login shell and enabled the serial interface using raspi-config.

My Problem
When I start mavproxy with sudo --master=/dev/serial0 --baudrate 921600 i get the following output, followed by endless waiting:

Connect /dev/serial0 source_system=255
Log Directory: 
Telemetry log: mav.tlog
Waiting for heartbeat from /dev/serial0
MAV> link 1 down

When I start the goto example of MAVSDK with the connect string serial:///dev/serial0:921600, it also block forever without generating any output.

Noteworthy hints

  • I have two drones of the same type available and the other one shows the exact same behaviour with the same RPi and a different cable.
  • I connected the RPi to a Pixhawk 4 and was able to connect.

disable flow control, use an usb

Hi @blank-supportgis ! Just to be sure, with the exact same settings on the raspberry Pi 4:

  • Two different Pixhawk 6c do not work
  • One Pixhawk 4 works

Are you using the same parameters and firmware in all the boards?

Try with these changes: fmu-v6c: fix Telem1, Telem2 without flow control by julianoes · Pull Request #21540 · PX4/PX4-Autopilot · GitHub

1 Like

Thanks for the help, but I figured it out.

One (or both) of the following settings did the trick:

  • MAV_1_RADIO_CTL to disabled
  • MAV_1_FLOW_CTRL to force off