Radio Not Ready fault during first set up (+can't fit mag 1 fault)

Hey everybody, I’m pretty new to this stuff. I’m connecting a RadioMaster Pocket to a Pixhawk 2.4.8 clone through an RP3 RadioMaster receiver. The devices are all charged, and the radio is bound to the receiver. But when I go to QGroundControl to set up the radio, every time I press Calibrate, I get a message saying, “Radio Not Ready, Please turn on transmitter” (attached below). I know that the radio is connected because when I unplug the Pixhawk, the radio says, “Telemetry lost”. So what should I do now?

Also, when setting up the Compass, I keep failing because of a “can’t fit mag 1” fault (see attached). I suspect that either the compass in the Pixhawk or the GPS module is faulty. Not sure if this is related to the issue above though. Any advice would be appreciated. Thank you.

Processing: Screenshot 2024-01-14 174016.png…
Processing: Screenshot 2024-01-15 224045.png…

I am on a similar situation right now, have you fixed this?

I think I have all the params properly configured, as COM_RC_IN_MODE:

Also, the radio and the receiver are bounded, but the same error:

Any help is very welcomed, please.

Hi, I still haven’t figured it out yet. I changed and tested all of my hardware and connection ports, and updated all of my softwares and firmware. Still no luck.

Ohhh, sorry to hear…
I have as well a Pixhawk 2.4.8, and I also had a lot of trouble to calibrate some sensors, as the compass… or even after calibrating it, it started working wrongly after a few tests…
I am suspecting my unbranded Pixhawk 2.4.8 comes with a bad quality or buggy hardware (mine was sold by a prestigious local RC shop, but no manual, etc: I suspect they just resell the usual AliExperss Pixhawks, although you have them at home in 24h)… I think I will try something as a Holybro if I cannot figure this out in a couple of days.

I will keep you updated

That’s possible, yes. But I’ve already done that and the problem still persists. I’m going to try a last ditch effort and connect the AR 620 to my flight controller through a PPM encoder instead of directly through the DSM ports. Maybe that’ll help. I’ll let you know.