R9SX (Sbus) no radio channels


According to the documentation the R9SX reciever can produce SBUS OUT on CH6 r9sx

I have a simple setup (see pictures). I connect Pixhawk mini RCin with CH6 (-,+,SBOUT) I have done the compas calibration & motors test but I have 0 radio channels in the MissionPlanner. Could be my r9sx damaged or i missed something ?

My radio and frsky r9m 2019 and r9sx reciever are flashed with the latest firmware
My r9m bind automatically with the r9sx (green solid led)
I tried to mix inputs to diffrent channels on my Taranis

My setup:

vers: 2.3.10-otx (7ac1ecb6)
date: 2020-10-12

r9m 2019 module
2019: FW-R9M2019_ACCESS_V1.3.0 (LBT)

FW-R9SX-v1.3.2 (LBT)

Pixhawk mini (FMUv5)

You need to go into to the settings for the model. select the receiver, then select Options and set CH6 to SBUS.
Like this:


As you can see on my picture (see above) the SBUS is already configured on pin6. I also set the channel range to 1-6. Any other ideas ?

Sorry your display is different than mine I did not get it.
Do you have CH. Range = CH1-16? I think 1-6 won’t work. I had that set wrong and it did not work until I set it to that.
Also are you using Mission Planner or QGC?

I am using MissionPlanner

I tested 1-4, 1-5, 1-6, 1-8 and 1-16. It change the number of buttons/controls available in the MissionPlanner (so they comunnicate somehow ?), but the bars in the missionPlanner are not responding to Taranis inputs.

Sorry but you will need to go here for Mission Planner questions. I don’t use it myself and here we support QGC:

It’s the same in QGroundControl / Radio Setup. When i click on calibrate i get the message Detected 0 radio channels. To operate PX4 you need at leas 5 channels

That most likely means that the FC is not seeing the SBUS signal.
At least that is when I have gotten that message.
From what you have said it appears that you have things set up correctly.

What set up have in done in OpenTX, or on the radio? By default there are not 5 channels setup.
Also did you leave the Channel Range at 1-16? IIRCC that was the last issue I had.


Finally it works. It’s hard to say where was the problem because i started from scratch I flashed all the firmwares and so on. I see several potential pitfalls.

  • I noticed a small difference between firmware upgrades with MP and QGC. With copter 4.0.5 uploaded to my Pixhawk mini the B/E led was blinking. It is not the case with the lates firmware uploaded with QGC. It is not necessarily an error It could mean “autopilot needs to be configured or calibrated before flying” (Pixhawk UI leds)

  • I think each time i force the bind (once you register your reciever it is automatic) or I change the number of channels the R9SX CH6 configuration is reset. There is a big big chance I forgot to set up the SBUS output that when I tested CH 1-4 to 1-16 configurations in a random order

  • I read this comment Pixhawk 4 mini FrSky Sbus port Problem and I wonder if it is possible to switch between PWM/SBUS modulation or reset the SBUS option by holding the bind button to long (I dont want to jinx so I will not test that). It is not documented in the r9sx manual but this functionnality is implemented on many other frsky recievers (FrSky website)