QGC fails downloading parameters upon startup

I have flown Friday with Windows and QGC versions 4.2.3 (on Win10) and 4.2.6 (on Win11) (two different laptops), PX4 v13.3 and Orange Cube. Datalink is Ubiquiti Rocket and distance between ground and air system is roughly 10 m, and the connection is solid based on the Ubiquiti interface and Mavlink Router onboard serving the connection on UDP. I am experiencing that the connection process with downloading parameters is highly inreliable. More often than not, it fails downloading parameters and I have to restart QGC or force a refresh multiple times before it succeeds (seems random to me). I did experience somewhat of the same issue using TCP, but there it actually retried until it worked, while it does seem to hang on UDP. However, TCP is not desirable once we start flying further away and get communication glitches. I tried Mission Planner which did not have any issues connecting and downloading parameters using UDP, which leads me to suspect QGC, but there may also be something else entirely. Any suggestions and comments are more than welcome.

Looking at the log file, it lists a large number of errors of type “[mavlink] unknown parameter ID:”. I do not understand if this is because QGC is requesting a bunch of parameters the autopilot doesn’t recognize or what is happening.

Another update:
It seems this message comes from here: PX4-Autopilot/src/modules/mavlink/mavlink_parameters.cpp at fc357921fd69e574a3f596be25faa8f4d9cdcea9 · PX4/PX4-Autopilot · GitHub

Which is from the autopilot. I am still quessing it is due to some QGC call since it does not happen with Mission Planner. It doesn’t happen every time, but it does happen more often than not.

Any suggestion is welcome.

Issue opened here: Failure to download parameters upon startup · Issue #10749 · mavlink/qgroundcontrol · GitHub