Px4flow Sensor

#1

Hello,

I am using px4flow sensor in Pixhawk4.
When I am using in stable firmware 1.8.2 it’s not showing any distance for distance sensor and any data through MAVLink Inspector related to px4flow sensor.
When I am using master firmware it’s showing all the data from px4flow sensor. I am using I2C port.

Although px4flow working fine with direct USB with QGroundControl.

Can anybody help me to use px4flow sensor with stable firmware?

#2

Hi I’d got one and would like to test it, but cannot locate a Windows 10 driver to configure with MP or QGC . Do you have one you could share? Once I get it going I will share my results. Thx, Jack

#3

I tried so many times but didn’t get driver for windows 10 even I tried driver signature disable to but still didn’t install.

So finally I switched to Windows 7. Here it install automatically and working fine with QGroundControl.

#4

I have a Win 10 desktop and a Win 10 laptop. The desktop COM port driver for the camera doesn’t work, but the laptop connects straight-away. There is a slight difference in the driver name. The camera worked fine with Mission Planner on the laptop.

#5

Same issue here.

The px4flow doesn’t work with the 1.8.2 stable release. No data for optical flow show in QGC.
Works fine with the master firmware and also through USB.

typing px4flow start & gives
“px4flow [388:100]
WARN [px4flow] scanning I2C buses for device…”

typing listener optical_flow gives
“never published”

Any fixes?