Pixhawk 4 + px4flow Troubleshoot

Having a problem with the PX4Flow from the start.

I have followed the User Guide Here:

The Windows Driver guide, which I saw in a google forum Lorenz Meier linked to, no longer exists on the Pixhawk site.
When you point the Device Manager to the driver, Windows says that it’s not a valid driver.

Opening QGroundcontrol v3.4.4, QG sees that the px4flow is there and has no problem reflashing. The first error pops up and says the PX4Flow on Port 16 is not found. So, doing the next steps are not possible.

Connecting directly to the Pixhawk 4 afterwards, QGroundcontrol and Mission Planner do not recognize the PX4Flow. I have tried going from the I2C to I2C, UART to I2C, I2C to I2CB (as recommended in a forum), but nothing seems to work.

Any thoughts or help?


Having the same problem!

1 Like

Having the same problem! I literally tried four different px4flow kits and none of them work!

1 Like

I was frustrated as well, and even went as far as trying on Linux. Nevertheless, I finally got it going on my Win 10 Dell laptop. Not sure why the driver is different vs my Win 10 desktop which failed (the driver names are slightly different). So it is now working with Mission Planner on the laptop. So recommendation is to try on a different computer.

Interesting. I have a Win 10/Dell laptop as well. Is this after the most recent update that happened within the last 48 hours?

No, it was earlier. Also - (for newcomers reading this) and it’s been mentioned in the past - be sure to use a USB data cable. Not all “USB cables” carry data.

The Dell driver is usbser.sys ver 10.0.17763.1 (WinBuild 160101.0800).
My desktop it’s 10.0.17134.1 (WinBuild 160101.0800).

Similar issue of connect PX4FLOW to Pixracer is discussed here: Pixracer with px4flow
To obtain data in Pixracer from PX4FLOW via I2C - you should connect PX4FLOW I2C to GPS of Pixracer (NOT telem 1/telem2).
There was also a problem with sonar data - after I soldered 5V power jumper on PX4FLOW and square jumper on sonar - sonar data also appeared in Pixracer.

After all, Pixracer does see all PX4FLOW data, but does not yet switch to POSCTL mode - will continue debugging…