PX4Flow not recognized by QGC 3 with PX4 v1.5.2


I’m trying to get PX4Flow to work with Pixhawk (PX4 v1.5.2) and QGC 3 (I’ve tried 3.0.0, 3.0.2).
Here is what I did:

  1. Update the PX4 firmware with QGC via USB
  2. Update the PX4Flow firmware with QGC via USB
  3. Connect the Pixhawk to PX4Flow via I2C
  4. Power on Pixhawk, start QGC

I don’t see anything in QGC… No PX4 Flow tab.
The PX4Flow has a solid green power light, an orange blinking COM light, and a blue blinking ACT light.

Am I missing a step?
How can I debug this?
Can anyone verify that this should work with QGC 3.0+ and PX4 v1.5.2?


If I connect the PX4Flow to the Pixhawk via I2C and connect the PX4Flow to a computer via USB (no radio) I do see the PX4Flow tab in QGC.

However, if I then disconnect USB power on the Pixhawk and connect via radio, I see no PX4Flow tab in QGC.


So it looks like somehow this problem is at the MAVLink layer…
There should be a MAVLink message “OPTICAL_FLOW_RAD” at 1 Hz in normal mode but I don’t see this in the QGC MAVLink Inspector or Analyze widgets.

SDLOG2 does seem to save what looks like reasonable data to the SD card.

Have you tried to debug this via NSH. I facing an issue with the I2C port on Pixhawk. That could be one reason.

I have not found a solution yet.

I’m having the same problem when after i successfully updated the firmware onto the px4flow, then QGC said that it fail to create a COM Port to connect the px4flow.