Px4 firmware upload error

Hello everyone, i am running a VM on my windows machine. I am following the tutorial and after i build the px4 firmware i copied it to the windows environment and tried flashing it using QCG but i am seeing this error:
Found device: Pixhawk
Connected to bootloader:
Version: 4
Board ID: 9
Flash size: 2080768
Downloading firmware…
From: C:/Users/…/Desktop/px4fmu-v4_default.px4
Download complete
Downloaded firmware board id does not match hardware board id: 11 != 9
Image load failed

i get it that the board ID is 9 … but how can i get around this issue.

If you download custom firmware, you should match the v# of firmware file
for example, I use px4fmu-v2_default.px4 not px4fmu-v4_default.px4
plz check the number, and try with another firmware file
or you also can upload the firmware using QGC without firmware file, but it needs internet connection

How will changing the file name change the firmware board ID …btw i tried what you suggested but it did not work. I see the same error.

this is the px4 firmware release link.
First, you should choose the firmware version.
After that just download the firmware.zip file of that version
you may find several firmware files in firmware,zip,
such as ‘px4fmu-v3_default.px4’ , ‘px4fmu-v4_default.px4’ and etc.
Then you can try those firmware files.
In my case, I use px4fum-v2_default.px4 file, and others dont work.

If you built it yourself, you used the wrong target.

Instead of make px4fmu-v4_default, use the version according to your hardware.

Thank you so much guys for the help … i will try this and see if that helps.

Thanks for the detailed explanation … appreciate it.