PWM control - Arms but no spin

Hey All,

I am having a problem where the PX4 (v1) is not outputting a PWM signal when the vehicle is ‘Armed’.
This is using the latest ‘Stable’ PX4 Firmware. ‘Master’ fails miserably at doing anything (crashes mid-boot) on the PX4, so i used the latest ‘Stable’ instead.


  1. I calibrated the ESCs (Plush 30A) using the QGC calibration.
  2. I set the PWM_MIN to 1400, no effect.
  3. The motors DO flicker every ~1 second while disarmed (I believe it is just to keep the escs ready).
  4. Quadrotor is in ‘+’ formation.

Any help?

If it is relating to the ESCs, how do I solve this problem (is the PWM frequency too high, if so how do i adjust in QGC or by other methods?)?

I would have uploaded the px4log file, but this system would not let me.


I tried manual calibration via the reciever. This worked.
However, the quad’s px4 pwm outputs are still not spinning the motors when armed.

Help please?

I am quite new to px4 and have little understanding about the whole architecture of px4.
I found similar problem with master build as described in my post.
Motor armed before pushing safety switch and not arming after safety sw on)

When I build the stable branch and uploaded, I could arm and motor spin.
Looks like there is some bug in the master branch maybe?

is your transmitter fully charged?

You can record the f103 reg status in the log file to find the problem,maybe some wrong between 103 and 427 communication

@CaptainJL did you ever get this resolved? I’m having the same issue

Does your ESC beep the correct initialization sequence after hooking up to pixhawk?

Some ESC don’t arm unless they first see a PWM under some threshold (see your ESC manual). I guess this is for safety reasons, to prevent props from spinning up immediately at arm. For mine it was 900, try setting PWM_MIN to a lower value in QGC?