Pixhawk4 Mini Position Mode Problem


I am using the PX4 Mini from Holybro for my homebuilt quadrocopter.

It is flown in Stabilize, Altitude and the Position Flightmode. Flown. Stabilize and Altitude works great, clean flight behavior. If I then switch to the position mode, the flight movements become hectic and unsteady. If I give pitch forward, it picks up speed and then in between again and again every few meters jerky braking maneuvers. I have already worked a lot with the PID values of the control, but I can’t get it to work. The behavior also occurs with the roll axis.
It is as if the control impulses from the GPS are too strong.

Is there perhaps a variable with which one can influence the access of the GPS?

As ground station I use QGroundControl with which I have loaded the PX4 firmware stable version 1.11.2. I would like to load another version of it, unfortunately, this does not seem to work with QGC. When loading the firmware, only this one path is displayed.


From another forum I learned that with this FC from Holybro also Ardu firmware works. Unfortunately nothing happens when I mark Ardupilot in QGC.

Does anyone have an idea about this?


Hello, the same here… I’ve updated to the new version of PX4 firmware and since then the position mode is very unstable when I move the sticks. I move the stick slightly fwd and it goes like crazy backwards, forward, then suddenly stays still… In the previous firmware version all worked great. But not now…

hello, i recent install last version PX4 1.11.3. in Cube harware with Herelink transmitter.
With Altitude or Stabilize mode it flight very well , after tune some PIDs. very fluid,
In auto mode with waypoint too.
But in Position mode it shakes a lot. if move the stick slightly fwd it moves in the same direction but makes a lot of brakes .no fluid

i dont know with older versions of PX4, because i allways used Arducopter firmware.

with lastest firmware. position mode works with no problem. may be the new smooth mode…