Pixhawk4 dronekit not connected

Hello. I am writing here with a sincere heart.

I made a drone app using dronekit-android two years ago.
The FC I used was Pixhawk2.

This time, I am going to connect the app to pixhawk4 as it is. However, development of dronekit has been stopped since 2017, and all links to the manual are blocked and cannot be accessed.

I tried to communicate by connecting the MAVLink WiFi Bridge to the TELEM2 terminal of the pixhawk4, but the connection with the QGC works well, but the dronekit does not.
I think something went wrong with this upgrade from pixhawk2 to pixhawk4.
I haven’t done much with dronekit so I’m not quite sure how to fix it. Everything is difficult to understand and vague.

I want to use dronekit with pixhawk4. However, pixhawk4 does not seem to be compatible with dronekit, which was released in May 2018 and stopped development in 2017. Is there any way to use pixhawk4? Is there really only way to downgrade to pixhawk2?

Please help me a little. Thank you very much for any interest.
A huge thank you to you for your time. May all good luck be with you.

@Serahan I think mavsdk took over the place of what dronekit was trying to provide previously

Technically, your problem is not related to the hardware version (e.g. pixhawk4 / pixhawk2) but the mavlink version you are using in the firmware that is being run.

You would have much better interfaces through mavsdk now, so I would suggest moving over to mavsdk.