Pixhawk power module current sensor pin not working

It is probably not the best way to get reliable power modules, but we currently buy cheap ones from the local RC shops or Banggood or Ali Express and throw them away if they don’t work as expected.

However, I have found several that work perfectly, with stable power to the flight controller and accurate battery voltage readings, but with bad current sensor readings.

A sample log is here:


I use a big BAT_A_PER_V to amplify the noise. The flight controller gets a stable input, and the battery voltage measurement is accurate within 1%, but the current measurement is 0 with a bit of noise.

The module is this one:

Has anyone tried this PM? Is there a hack to get valid current readings from it?

I don’t know if it makes a difference but the cheap ones I use have a blue colored pc board similar to this. They’ve worked well for me.

Good luck.

Did you find any reliable way?

@Darshan_Jain no insights unfortunately. I just tried another one and it worked. My “solution” is just to keep a couple spares around in the lab just in case.

I’m getting a current value as constant zero and I’ve tried a couple of power modules as well.
Thanks for letting me know.

If it’s consistent for multiple power modules, one possibility is that you’ve consistently got the battery connected to the wrong side of the power module? Just a thought.

I had a similar issue. At first I plugged in the current sensor such that no current was moving through it (obvious zero reading). Once I corrected this, I plugged in the current sensor backwards (also gave zero reading, The XT-60 connectors were deceivingly placed and theres no direction labelling). After fixing both of these errors, I was able to get mine to work.