Pixhawk 6c Strong Magnetic Interference

I am wondering if someone faced this issue before
I am having many errors with PX4 1.14 Beta, these errors are showing in QGC as:

  1. Preflight Fail: Yaw estimate error
  2. Strong magnetic interference
  3. Preflight Fail: Heading estimates not stable
  4. Preflight Fail: attitude failure (roll)

I have to use 1.14 beta to be able to use the MicroDDS with ROS 2 foxy.
I tried to re-calibrate the Pixhawk 6c outside the building by carrying the flight controller only to avoid any interference, and I am still having the same issue (although I will be using the quadcopter in-door).

These errors are not showing with Px4 1.13.3 stable release.
I performed a forced arming through nsh (mavlink console) and here is the log file


The Pixhawk is new I just got it last week

1 Like

My guess is that you have the same interference with v1.13 but it’s not as good in warning you about it yet. Indoor there is often magnetic disturbance from iron in walls, floor or the ceiling, so that could be a problem.

Let me ping @bresch maybe he can shed some light on this.

@JulianOes , you are correct,
V13.1 has the same issue but doesn’t show any warnings.
I notice that there is drift in the compass measurements.

OK, I fixed it,

the problem was coming from the internal compass.

The soultion is to connect an external compass and make sure it is properly connected to the frame aligned at the same direction of the flight controller, and then perfume the calibration.

1 Like

Do you think your internal compass got compromised due to some reason. In my case I am using Pixhwak 6C with the M8N GPS+Compass module. It was working fine until few weeks back. Now the compass is always drifting from the right direction however I try to calibrate it.