GPS Orientation - Pixracer - mag sensors inconsistent

#1

I have purchased a new Pixracer R14 and ublox neo-m8n gps with hmc5983 compass from mRo and have a few issues and questions.

Part 1. Im not having much luck and get a “mag sensors inconsistent” error. I have aligned the GPS/Compass as per the arrow on the board. See photo but this arrow is not consistent with the X arrow (XYZ diagram) on the underside of the unit. Do I follow the top arrow or the X on XYZ chart in the underside?

Part 2. Because the hmc5983 compass is mounted on the underside of the GPS/Compass unit do I need to apply 180 rotation in QGroundcontrol for this unit?

Part 3. Why do I see three compasses in Qgroundcontriol Mag0, Mag1 and Mag2?

Thanks in advance.

Addendum:
I have disabled MAG0 (the external) and recalibrated in the two Pixracer Compass MAG1 and MAG2. Much better result. I also tried disabling the Pixracer Compasses and only ran with the external compass and found it wandered all over the place.

Addendum:
mRo have very kindly offered to inspect repair/replace item. They have been very helpful however since i have it working without the need for the 3rd compass im going to keep it.

#2

I had this same issue and found better results by disabling MAG1 and MAG2 (internal mags) and using only the external compass as it is further away from noise and interference coming off the motors, power distro board, etc…

don’t think this is a hardware issue but rather the internal mags might have an offset that is not set in px4 as of yet

#3

Thanks. Any ideas on how to check the off set on each of them ?

#4

working on it… since using only the external mag has worked well, i put the issue on the back burner but ideally the unknown offset will be set as a default parameter for the next release.

#5

Seems this issue was resolved in master as of today

#6

Good to see it wasn’t something I did. It was driving me nuts. I installed Arducopter and the issue went away. I will have to give PX4 another go now.

#7

I have got exactely the same probem. I am using the latest stable release 1.8.0.

Any idea how i can fix this issue?

Thanks,
Regards Tom

#8

According to Santiago_Escala who commented in this post the issue was fixed. I resolved it by disabling the affected compasses. Also i did try arducopter and it wasnt an issue anymore so i stuck with arducopter.

RM

#9

OK.
but disabling the compass(es) is not really a solution i think… thats just a workaround

but i will give arducopter a try and see how the the experience is with that.

Thanks for your contribution rusty :slight_smile:

#10

I have had the same problems with a mRo Pixracer and the mRo dual compass. Was possible to fix by rotating the compass from the original setting indicted by the arrow printed at the USB contact.

I rotated the unit so the printed x-coordinate (for the LIS3MDL compass) now is pointing forward. I have the Taoglas antenna pointing to the sky and y direction is to the right hand side seen from behind. A calibration with setting “Rotation None” for the external compass gave a perfect result and eliminated “Magsensors inconsistent” for good.

I stumbled upon the solution by using FlightPlot to visualize a log taken when rotating the drone along yaw and z axis. This revealed that x and y directions were different compared to the internal mags and also that the QGroundcontrol calibration rotation parameter did not at all work as I had expected.

Qgroundcontrol version was v3.4.0 and firmware version is 1.8.1.

1 Like
#11

Good day, today I’ve installed the new px4 firmware 1.8.1 i didn’t not find any issue about the compass calibration with mro pixracer and mro x2.1.
I think was an issue on the previous version 1.8.0.
I will test it again tomorrow.

#12

My approach on compases and avoiding inconsitancies is to use only the compass in my GPS unit. This is likely to be the least interfered with. Ask yourself if it is vital to have a backup compass? Failure likelehood must be very small, and consequences not that fearfull.
I think a second inbuilt compass in a flight controller is likely to be through the serendipitous presence of of a chip with an embedded compass. It’s there so make it available! Any inbuilt compass is unlikely to be as good as a GPS compass.

1 Like