Pixhawk 4 Peripherals Issues

I have encountered issues connecting peripherals to the Holybro Pixhawk 4 flight controller to be used in a single motor, conventional fixed wing UAV aircraft.

  1. The airspeed sensor came with a JST connector, designed for the Pixhawk 1 but incompatible with the Pixhawk 4. I have attempted to solder the cables in the right order to fitting GH1.25 male connector. When I connect it to the I2C port on the Pixhawk, the sensor overheats and is not recognised by QGroundControl running on Win 10.

  2. The telemetry radios I ordered can connect to the Telem1 port on the Pixhawk but cannot connect to the PC as the output is a USB OTG microB. Will a USB micro to USB C adaptor work if connected to a smartphone? Is there a way to connect it to a PC so it can interface with QGroundControl?

  3. The PMW out cables do not output the signals from the RC receiver.

Explanation of the setup:
The SBUS port from the receiver connects to the SBUS RC port of the Pixhawk. (Confirmed by QGroundControl, moving the control sticks show up on the screen)
5 V are supplied to the receiver through the PWR 2 port on the Power Distribution Board. (Confirmed by green LED)
I/O PWM out cables from the Pixhawk connect to the I/O PWM in port on the Power Distrib. Board
FMU PWM OUT -> FMU PWM IN
ESC power cables connect to B+ and GND on the Power Distrib Board.
ESC yellow wire to be soldered on the M1 next to B+ and GND, for throttle control.
BEC 5V from ESC to FMU PWM OUT rail on PowerDistribBoard. (Confirmed with multimeter)
4 Servos to be connected to the FMU PWM OUT rail. (Do not currently receive signals, only current, as holding torque noticeably increases)

I will be grateful for any help you might provide.

Those telemetry radios use a regular micro USB cable to connect to a PC (not an OTG). If it’s not being recognized, you may need a driver. However, it is annoying that the Pixhawk 4 does not come with a 6-pin ClickMate to JST cable, so to connect the radios to the Pixhawk you have to make your own cable.

As for the PWM out, make sure that you’re armed and not connected to the USB. You can disable the USB check in the Parameters by setting the CBRK_USB_CHK to 197848 as described here
https://dev.px4.io/en/advanced/parameter_reference.html

1 Like