Pixhawk 4 doesn't reboot automatically after brownout (sometimes)

Hi guys,

I have a strange issue with Pixhawk 4. This happened the first time when I stalled a servo until it melted :man_facepalming:. The brownout caused the Pixhawk to power off (fine), however, even after the melted servo stopped smoking and no current was going through it, Pixhawk wouldn’t boot back up itself. After disconnecting and reconnecting the battery, it booted up as usual and everything worked fine.

Why do I care then? - If this had happened in the air, I would have lost the plane. The desired reaction would be that the Pixhawk boots back up when it detects enough power available.

This made me investigate a bit more into what is going on, and I can say that this is not a sole incident. I can reproduce it with about 50% success rate if I short the power board on purpose with a smoke-stopper connected, or if I just short it with a 6A polyfuse directly, you could think about other ways to achieve this. After you remove the shorting, Pixhawk won’t boot up. Instead, very tiny ticking sound is coming out of it, I suppose similar as when you try to power it with something under 5V.

I tested this on two different Pixhawk 4 and PM07 board sets. Firmware PX4 1.9.2. To test if it is not a power distribution board issue, I powered the Pixhawk using a second battery-pdb set to the second power port while the ticking was still going on and then removed the first pdb. Still ticking, no reboot.

My question is, is this a feature or a bug? What can be done? I don’t want a single burned servo to turn off the whole plane mid air. EDIT: (for no longer than necessary)
Can anyone say if this happens with other controllers too, like the Cube or Durandal?


I assume you tried to use the Pixhawk power module to power the servos?

You are not supposed to power servos off the Pixhawk power module. You should always use a separate BEC that you connect to one of the servo rails in order to power servos. Otherwise, you are drawing from the same power source as Pixhawk is powered and will inevitably cause it to brown out if you draw too much.


Hi Julian,

that is interesting, what are the power outputs on the PM07 Holybro power distribution board for then? I am not powering the servos from any of the Pixhawk 5V outputs as I believe is implied in that thread linked.

I already use separate LiPo for the ESCs. The second LiPo powers servos and Pixhawk. I agree that having a separate LiPo for everything may be safest, but that is not really the point here.

My issue is, what happens AFTER the brownout, why the Pixhawk is not restarting?

I tested it with PX4 1.10 and the last release Ardupilot as well and it happens for both so I suspect it’s a hardware issue. Unless it is a desired behavior of course.


Hm, right. I forgot about the fact that power module is part of the power distribution/ESC connector board for Pixhawk 4. I assume it actually still is not supposed to provide power for servos.

I don’t think you need separate LiPos but you just can’t power servos and Pixhawk off the same BEC, the servo will always potentially pull voltage too low and brown out Pixhawk.

And I don’t know how brownouts work but to my knowledge you just never want to go there, no matter if/how it recovers, so I disagree that this would be the issue.

@david_s5 maybe you can help me out here? Thx.

@JMshare What all it connected to the FMU and where are you applying short?

It’s connected as shown in the picture.
I am basically shorting the LiPo there for a brief moment. You may be able to replicate this using a variable power supply that get’s you just under 5V.
It may look like a silly thing to do but it’s just to show what happens when a high voltage Futaba servo gets mechanically stalled until it melts.