Pixhawk 2.1 preflight: GPS Receivers Missing

Hi guys,

Has anyone tried the new released Pixhawk2.1 with PX4 flight stack? I have configured the copter using QgroundControl, everything seems fine until I tried to arm the copter, i kept getting the error message preflight failure: GPS Receiver Missing, and the copter is not able to arm. I have searched through the parameter list and made sure that GPS check is disabled for arming.

Any suggestion is welcome. Thanks in advance.


GPS receiver missing alarm is reported if GPS not connected, however you should still be able to arm.

I see… that means the problem might not come from the GPS. There is another message that simply says preflight check failed, without specifying what the error is. May I know how do I check the specific error that prevent the copter from arming?

How do you have it connected? Right now it has to be the larger GPS 1 port which breaks out to GPS, MAG, Safety button. We don’t currently automatically start the gps driver on the 2nd smaller port.

Hi Guys,

I’m experiencing the same problem on the Pixracer with firmware v1.5.2. There also seems to be a problem with 3dr telemetry modules I’m using. They won’t connect. I don’t have this problem when using v1.5.1.


Hi, i dont use PX4 for my pixhawk 2 but with ardupilot I can not get my telemetry radios to connect either. I tried to flash the px4 firmware to see if it made a difference but it still wont keep a connection. I have tried switching radios firmware and ports… makes me think its a pixhawk 2.1 issues??

Niker: this may be a connection or cabling issue, have you checked the TX and RX pins are connected to the right ports? In the documentation of Pixhawk2 you can find out the exact TX and RX pins for telem port.

If it is still not working, you may want to find out whether there is signal coming out from the ports. If not, then it is likely a hardware problem.

Hi dagar,
I did not connect it to any GPS, so I guess the error message is common, and it is something else that caused it not able to arm… But I can’t figure out what is the error that caused the preflight failure.

Sounds like there might be something to fix here, but one last thing to check, is the param COM_ARM_WO_GPS set?

Hi Dagar,

yes I have checked that parameter to allow arming without GPS. Thanks.

This patch should fix it. Can you try it?

Hi Lorenz,

I help loaded the latest master into pixhawk2, the message of GPS Missing disapeared. However, I am still not able to arm and the message is Not Arming: preflight check failed. I suspect it is not something about GPS. All my sensors and RC channels have been calibrated and seem to be normal, so I caanot locate the root of the problem.



Have you checked that the safety switch is pressed and flashing faster?

yeah…that was the first thing i checked


I am having the exact same problem as MQC. I checked parameter with and without GPS and its still stating “Preflight checks failed”.

Please advice.


I am not a programmer. But if you can help with this issue it would be great. I am currently doing my university project and I am stuck with this problem.


Do you see any other messages before that?