Pitch control not working in flight mode

I’m on a college research team and we’re working on interfacing a Logitech Flight Yoke System to our plane which is using pixhawk 2.4.8.

We are able to get everything working remotely through the actuator menu in qgroundcontrol but, when we switch over to flight mode, the pitch control is unresponsive. We’ve measured the output pin assigned to pitch with a scope and it’s outputting a square wave but it is unresponsive to input from the controls. BTW, We’re using the standard plane airframe.

Anyone have some ideas on troubleshooting methods? Maybe there’s something we’re missing in the controls mapping or there’s a different airframe/mode we should be looking for? We’re all pretty new to both pixhawk and qgroundcontrol.

Thanks in advance for any advice!

Which flight mode are you using? And which version of PX4 is that?

We are in manual flight mode and its px4 stable on the pixhawk 2.4.8

Can you share the log of the flight by any chance? You can just upload it to logs.px4.io and then post the link here.

Sorry for the delay. We have figured out more specifically what the problem is, the elevator servo is not connected to the pitch control on the joystick. We accidentally discovered that the elevator is instead controlled by the orientation of the pixhawk itself, almost like it’s in auto-level mode.

How can we disable this and set the servo to the joystick?

You need to figure out what PX4 mode you want to use: Manual, Stabilized, Altitude control, etc. This determines how the inputs are mapped.