Payload drop and servo pwm setting in mission mode

#1

i tried to use the qgroundcontrol setting (mission) to activate a servo to a specified PWM setting, but got no response (that was noticeable.
.
servo # in mission waypoint menu was “0”, pwm was 775.
pwm setting was 775, which was set in “min” for the aux1 servo (default remained at 1000)
.
i had rc channel 8 mapped to (passthru) aux1 for some tests, for others i unmapped the rc from aux1.
.
the servo works when controlled from the RC Tx even in mission mode. (if it is mapped in qgroundcontrol).
,
how do i use the payload drop commands (BD_*) ?

#2

What Pixhawk are you using? What version of PX4 are you using? What is the exact mission? What airframe and mixer configuration have you selected?

#3

hi @JulianOes,
CUAV Pixhack V5
px4 1.9.0
qgc 3.5.3
mission: RWTO; WP1=TO; WP2=WP; WP3=loiter(time); WP4=WP;WP5=WP;WP6=Set Servo=Servo 0, PWM 775; WP7=WP; WP8/9=Landing pattern.
Airframe: basic plane
mixer config: What you talkin bout, willis?
.
btw, I tried another method… using camera trigger on WP setting, camera trigger to aux1. camera trigger works when ‘tested’ (qgc camera page), but mission doesn’t.

#4

Ok. I don’t think the do_set_servo command for the mission is supported, so that could explain the problem.
Can you try the camera trigger in the mission then?

#5

yes. I did try the camera trigger (seend of previous post). it works when the qgc ‘camera test - “trigger camera”’ button is pressed (before arming), but mission with neither a start image capture WP or a WP with a camera trigger added produce servo activation. Actually, when I land and disarm, even the qcg “camera test - trigger camera” button won’t trigger servo movement any more. FC needs to reboot to reactivate.
.
I just noticed (running tlog) that I didn’t check the “mode” box in the camera add for the WP item. it is grayed out with “photo”, so I assumed it was ok. now, when I check that box, subsequent mission items’ numbers increment. I wonder if that will have an effect.

is there a parameter or “mapping” that i’m not aware of? tthen why would the test work but mission not?
.
btw,
trig_interface : generic pwm
trig_mode: time base, on command
trig _act_time: 3000ms
trig_pwm_shoot:775us

#6

No joy checking the"mode" box either. Couldn’t get any mission controlled servo to work at all. Can’t figure it out.

#7

So have you tried to use the camera trigger as part of the mission?

#8

is that different than what i mention in post#3 and post#5 ? i’ll take look and see if i can find a different option in the mission definitions.