"Parameter write failed" in QGroundControl with version 1.5.5


I’m trying to change the flight modes on my Pixhawk with PX4 Pro version 1.5.5. Some seconds after changing flight mode and switching menu screen, I get the following warning: “Parameter write failed: veh:1 comp:1 param:COM_FLTMODE4”, and the flight mode does not change.

I’ve also tried to change any other parameter via the Parameters menu. This returns the same type of message. I’ve checked the MAVLink Inspector, and I have heartbeat at 1 Hz, but no parameter messages are visible.

The strange thing is that the first time I powered the Pixhawk up after flashing, calibration and parameter adjustments worked just fine. After powering down and powering up again, I’m having these issues. Restarting does not help.

Responded to on Gitter.

Hey Don. Thanks for your response. I think the COM-link works fine (I get heartbeats at 1 Hz, and other MAVLink messages work just fine, as well as telemetry). I am also able to set/read parameters through the console. Any way to do debugging?

How are you connected? Radio? USB? Multiple connections? First step is try the same thing with a USB connection.

Thanks Don,

Running QGroundControl in Linux made me able to see the error output in the terminal, which helped me troubleshoot. It does indeed look like the connection is faulty. I used a 433 MHz telemetry set, and moving them around helped.

Again, thanks for your help.