Orange Cube no longer connects to QGround Control

Earlier today I tried to flash my Orange Cube with a custom firmware to use the crsf_rc module like in this article: Reptile Dragon 2 (RD2) Build | PX4 User Guide

Well it worked and everything was great. Then I changed a parameter that says ‘crsf_telem’ or something and that worked as well but the connection with qground control over USB died shortly after. I can flash firmware still, and I can connect for basic telemetry in mission planner but nothing will connect in qgroundcontrol. I have flashed back and forth to different FW and I get nothing. If I remove flow control from the link and manually start it in qground control I can see mavlink packets coming it at a somewhat crazy fast rate but it still doesn’t connect to let me edit parameters.

I have never been able to use ardupilot successfully on the orange cube so that’s not an option and without qgroundcontrol I can’t setup the sensors and options. Any advice or help?

To be clear - I have tried px4 v1.13.3 and 1.13.2. I have also tried the newest version of arducopter. In device manager I only ever get 1 com port -

1 Like

I would try to connect via Telem1 via an FTDI cable or a SiK radio. Then you should be able to reset the parameters.

What you could also try is to do add a file extras.txt in a folder etc on the SD card like and add a command to reset a specific param, or all:

param reset PARAMNAME
param reset_all

This script should then be executed on startup. Once done, make sure to remove it again ;).

Well, the telem1 on FTDI or Sik Radio did not work. Those were some of the first things I tried last night. I’ll attempt to work with the resetting parameters option. Do parameters not get reset when you flash new firmware?

The params don’t get reset. They are stored on FRAM.

Resetting the parameters worked well. This is a good thing to note especially when switching between Arducopter and PX4. Thank You for all your help.

1 Like

Nice! A contribution to the docs is always appreciated.

@hamishwillee where could we add to the docs how to reset params via SD card if a Pixhawk does no longer boot correctly?

There are a few places we might try. The question is how likely people are to find it. How about in a troubleshooting section at the end of Loading Firmware | PX4 User Guide?

Perhaps even better, a section in Parameters & Configurations | PX4 User Guide linked from a troubleshooting section in firmware above.

Seem reasonable?

1 Like

PS if this is likely cube specific, also link from cube docs

Yes, that would make sense.

@Christopher_Watson so that would be here: PX4-user_guide/ at 5b0147ca905bc5b1de5f5c72fac8703afc76ac65 · PX4/PX4-user_guide · GitHub

This is not really Cube specific.

Thank you all so much.

1 Like