Cannot connect to pixhawk after flashing 1.2.0

Hi, today I’ve upgraded my pixhawk to latest stable (v1.2.0) and I’ve found some problems. I’m using qgroundcontrol 2.9.4 on ArchLinux.

As per the instructions I’ve plugged the pixhawk only by USB (from a laptop) and then upgraded. After that, I could not connect to the board from QGC since I constantly got “Error connecting: Could not create port. Permission error while locking the device”. I have access to the corresponding device which is writable by uucp and I’m member of the group.

I tried connecting by first plugging the battery and then USB and also by powering only from USB. At first I managed to connect a few times, but now I’m not able to do so anymore.

What is more strange is that, when plugging the battery and not the USB, the ESC do not beep anymore. I’m afraid that something has happened to the electronics.

I tried re-flashing but the problem persists. I’m really not sure what to do or what could be the problem.

How can I debug this? If I connect manually to the board using gtkterm using the USB cable I don’t see anything on the console.

I see the right (I/O) amber light blinking it what it seems 4hz, which according to docs means that no fmu app is set. What could be causing that?

EDIT: I’ve tried flashing an older version of the stable branch (the one I had before the upgrade to 1.2) and the amber led light is definitely off after boot completes. Still, the problem persists. I’ve now flashed master, the amber led flashes again and again the problem persists.

EDIT2: with stable and QGC 2.8 I can connect as was before all this mess. Opening newer QGC shows a flaky connection, which seem to hold only if battery is used to power the pixhawk before connecting the USB cable (with QGC2.8 this does not happen).
However, flashing any newer firmware shows the aforementioned blinking amber led and it is not possible to connect in any way (with and without battery)

I managed to solve the problem. For anyone else out there migrating to 1.2.0: I had to go back to stable and use QGC 2.8 (as before) and request a reset of all parameters (in System tab of QGC parameters). After that I was able to upgrade correctly and now everything works as expected.