Only half of the motors are spinning

#1

Hey there,

I’m having an issue with my quad just spinning motor 1 and 2. I tested all four motors with an servo tester for proper behavior and rotation direction and they worked fine.

After setting up my Pixhawk through QCG and attempting to take off (props of course off) only motor 1 and 2 spin (also ramp up when attempting to launch).

Motors 3 and 4 on the other hand just jitter around a bit but don’t turn at all.

Is it possible that the FC tries to invert the rotation direction on its own? I’m not sure if it’s an coincidence that the CCW motors spin while the CW ones don’t.

Might this be possible?

Thanks!

Phil

#2

Did you wire anything differently for the CW motors?

#3

Nothing except for the swapped phases for the opposing rotation direction

#4

Where did you swap them? You mean the motor cables between ESC and motor, and not the signal cable from Pixhawk to ESC, right?

#5

The Signal cables are of course identical for all ESCs. I swapped two of the three wires between ESC and motor to achieve the required roation direction which I checked with the servo tester

#6

Ok odd, so that seems correct. :thinking:

#7

I just had the great Idea to test the not-running motors at the channels of the running motors. Shame on me for not trying this earlyer…
This would determin if it’s a hardware or software issue. As I won’t have access to the copter until tomorrow morning it might take a bit until I’m able to test this. I’ll post an update as soon as I tried it.

1 Like
#8

So I really don’t know how, but I managed to destroy ESC 3 and 4 somewhere in the process of installing the FC. I’m not even mad, I’m impressed. Fun fact: I have the knowledge and equipment to handle highly ESD sensitive devices so that’s quite unlikely to be the cause. I’ll investigate further and if it’s something interesting I’ll let you know.

#9

Ok thanks for the follow-up. That’s odd!

#10

Surprise surprise, make all ESCs work and the copter flies like a charm. Thanks for your Help!