PX4 - Tricopter Spinning

Not a new guy with Tri-Copters and have solved spinning issues in the past. But, this time I’m stumped.

I’ve been flying my copter for about a year with a PX4 - ver 2.4.8. A few weeks ago Mission Planner told me to either downgrade my version of MP or upgrade my copter Arducopter firmware. Yes, this a QGC forum and I’ll get there. :slight_smile: So, all attempts to upgrade the firmware through MP proved futile. Never have I had an issue like that. This brings me to QGC. Fired up QGC and was able to easily upgrade the firmware. Shrug!!

Currently using v. 1.6.1dev and have selected Tri-Copter Y+ configuration. This is a little concerning given there’s a Y+ and a Y- configuration as typically we like to run two motors in one direction and a third in another.

Quickly determined this firmware has different expectations for motor hookup. Instead of ch1 (front right), ch2 (front left) and ch4 (tail) with servo on ch 7 it appears to use channel 1, 2, 3 & 4 (servo). That’s easy enough. Current configuration is Front Right spinning CW on CH1, Front Left spinning CCW on CH2, Tail spinning CCW on CH3 and tail servo connected to CH4.

Issue: Copter spins CCW on takeoff.

Typically to fix this I reverse the servo channel. In this case I changed RC4_Reverse from 1.0 to -1.0. Unfortunately the copter still spins CCW. What reversing the channel appears to do is change my arming. Set to -1.0 I have to hold the throttle stick (Left, Mode 2) to the lower left (vs. lower right).

Anyone else experiencing this? Any ideas what I’m doing wrong? Do you want me to provide any additional info.

Thanks in advance.


I’ve concluded the PX4 firmware isn’t capable of controlling the tri-copter (keep it from spinning). Regardless of CH4 direction. Switched back to ArduCopter 3.4.6 - TriCopter and everything is well.

I am very happy with QGC. Once I flashed the firmware with MP I went back into QGC and used it to setup all parameters and perform all necessary sensor calibrations. Very happy with QGC in that regard. I decided to flash with Mission Planner as it wasn’t clear if I was going to get the TriCopter version of 3.4.6 if I flashed with QGC. But that’s not a biggy.

As a side note - just in case someone stumbles across this obscure post - I had a boatload of issues flashing the Pixhawk 2.4.8 as well as connecting to Mavlink (with either USB or STK Radios). Turned out my SD card in the Pixhawk was flaky. Pulled it out and reinserted and whalla - no issues flashing or connecting to Mavlink. Going to get a new one and pitch this one as it’s the second time I’ve run across cheapo SD cards that sort of work, sometimes, maybe.

I see a lot of posts in this forum go unanswered. So by replying to my own post at least I don’t get a big fat goose egg. :slight_smile:



It sounds like you needed to reverse the servo out (PWM_MAIN_REV4) rather than the RC input channel.

That’s excellent dagar!! Explains the odd arming behavior. I’ve been an ArduCopter guy for so long I need to learn a lot more about the PX4 parameters. Thanks.

I’m going to fly with ArduCopter loaded today and make sure I’m back where I left it before the firmware upgrade. Then I’ll switch back over to PX4 to compare.

Thanks again.


I haven’t seen many tricopters and those configs are pretty old. Feel free to ping me directly if you hit any weird little issues that have slipped in over the years.

@dagar and @edjack I had the exact same problem. I fixed it by switching to tricopter Y-. I don’t know why but I tried reversing the channels both from the radio and from the parameter but that didn’t work for me. As soon as I moved to Y- configuration, the spinning stopped.