Not getting px4flow values on pixhawk4

hi there,
I have an issue with px4flow on pixhawk 4.

On latest stable firmware ı can see the optical_flow_rad topic . However apart from distance, temperature and time values, all other values are zero.

When I reboot the pixhawk, optical_flow_rad topic is completely gone.
Then on mavlink console I write px4flow start -X 4 -a 0x42, optical_flow_rad topic is back, but same as before.

Then ı have tried other firmare versions, beta version was the same as stable version. However, on master version ı was able to get optical_flow_rad topic with all values (not zero values like other versions). However, when I reboot the pixhawk, topic is gone. Then I start the px4flow from mavlink console, I get the topic back. However this time with zero values.

When I connect the px4flow to pixhawk 2.4.8 there is no issue. I get the optical_flow_rad topic with values all the times.

I am stuck, any help would be really appreciated.

Best wishes to all

problem is solved,
those values were zero because there was no feature to track. Focus of the px4flow camera should be adjusted. Then the camera should see some features around. The only problem remaining px4flow topics are not on mavlink inspector on boot, ı need to write the command “px4flow start -X 4 -a 0x42” on mavlink console eveytime I reboot the pixhawk.

In my case after connecting 5v micro b type cable, it worked

still the values are not stable, sometimes I get the values from the topic sometimes I get 0 values, when I directly connect the px4flow to pc via micro usb, I almost always get values

Don’t you use ı2c connection ? How do you connect it with pixhawk with micro b type cable ? Can you share your wiring diagram.
Thanks in advance

sry to make you confused
I mean connect i2c(4pin wire) and power(normal usb cable from on board usb port to px4flow micro b type usb port for supporting power)