PX4FLOW start failed

My Pixhawk can’t get I2C ack from PX4FLOW and I got the console message as following:
nsh> px4flow start
WARN [px4flow] scanning I2C buses for device…
nsh> px4flow info
ERROR [px4flow] driver not running

I can see the flow video and sonar distance information on QGC via USB.

Can anyone help me to figure it out what happen to my PX4FLOW? Thanks!

I am running into the same issue. I have updated the PX4Flow’s firmware using QGC and I can see the video, but when hooked up to the pixhawk it does nothing. The lights flash but I get the same console messages. Any help is greatly appreciated.

Are you using QGC 3.x or QGC 2.9.x?

Hi AI_B, I am using QGC2.9.6.

Hi Al_B, I’m using QGC 3.0.0

Well, figured my issue out. Problem with the I2C cable. @takumi, if you made your own I2C cable, make sure that the wires are in the correct positions.

Thanks NCharabaruk. I double check i2c cable again and I can saw the i2c signal on PX4FLOW board by scope but there just no ack.

Ours had a problem with signal loss. Too thin a wire over too long a distance. The Pixhawk could see that there was a device attached but couldn’t see the data.

Thanks @NCharabaruk.
I think I will buy a new one but not now. It cost a lot of money…
By the way, did you fly indoor with hover mode or altctl mode? Is it good?

We’ve flown indoors but only on stabilize/manual mode. As we are working indoors we aren’t getting good altitude values, we need to get the LPE to only look at the sonar and ignore the barometer entirely but haven’t figured that out yet.

@NCharabaruk, what do you mean when you say you’re not getting good altitude values? Does altitude hold perform badly? Or do you mean the range used for flow fusion is bad?

For flow fusion only your distance measurements from your lidar are relevant.
If you are having problems with altitude hold because of the baro, have you looked at LPE_PUB_AGL_Z? That might do what you want (I haven’t tried it, though).

We haven’t tried altitude hold because when looking at the altitude value using QGroundControl the altitude it gives is quite different from reality and we’re worried that the uav will behave erratically.

I will take a look at that param and see what it does. Thanks for the info.

I am facing a similar issue on the I2C bus. And I can not get PX4FLOW sensor to talk to Pixhawk. I tried possible cable wirings, but could not get it working. Any advice?

I just solved my problem. The issue was that a broken cable!!