Px4flow quality = 0 issue

Hello, I am having troubles getting the px4flow board to send proper data to pixhawk 4 (I tested both the generic px4flow 1.3.1 from ebay and the CUAV px4flow 2.3).

  • I do the calibration steps as per instructions and have a clearly focused image at 1m distance which I verify with QGC connected directly to the board over USB
  • I connect the board over to pixhawk 4 i2c-2 port since I know there was an issue connecting to i2c-1
  • I enable the px4flow by setting ekf2 aid mask = 2
  • I check my px4flow driver through mavlink terminal and I see that packets are being sent and the i2c is correct and being recognized
  • I have a lidarlite v3 connected to i2c-1 and I see that the distance topic is being populated with the correct distance measurement
  • I load up analyzer in QGC and see that the flow_rad topic is being populated, but here is the problem - it is being populate with all zeros! even the quality =0, now I know it needs to be above 200?
  • the only non-zero value in the flow_rad topic is the timestamp
  • I look at my vehicle local position topic, and I see that both velocity and position are being populated, but they are actually being populated with what looks like filtered accelerometer data, weird! if I changed the ekf2 aid mask to 0, the position/velocity stays the same so I know the ekf2 is not using any px4flow data when bit mask is 2.

any ideas? much appreciated!

1 Like

Are you using master or the 1.8 release?

So when you say i2c-1 and i2c-2 you mean respectively the gps i2c port and the i2c-b port right? Moreover how are you checking that you are actually receiving i2c packets?
Do you mind sending the output of listener optical_flow from you mavlink shell?
Last thing, did you ever get this sensor working on other boards or is this your first attempt?

Sorry for the many questions but I would like to understand better your setup.

Daniele,

I tried this on both 1.8.0 stable and master.

Also will mention I tried this with all 3 versions of px4flow: v1.3 original from holybro , v2.3 from cuav, and 1.3.1 from eBay.

Yes, by i2c-1 and i2c-2, I meant to say i2c-A and i2c-B, right now it is connected to i2c-B.

Here is what I did to check for packets and then listen to the topic:

I tried this sensor on another identical Pixhawk 4 board andgot same result.

Is this issue solved?