No throttle / ECS beep PX4

My setup:

PX4 FW 1.8.2 stable
QGC 3.5.0

ESC with 5VBEC

QGC-PX4 Parameter:
System -> SYS_USE_IO enables/disabled both tested

Airframe Reference:
—————————

Generic Flying Wing
MAIN1: left aileron
MAIN2: right aileron
MAIN4: throttle

Connection between Pixhawk 4 --> PM board:
—————————————————————
I/O PWM OUT --> I/O PWM IN
FMU PWM OUT --> FMU PWM IN

Wiring:
———
ESC signal to M4 PMB
or other try
ESC signal to FMU-PWM-out PMB
ESC +/- to FMU-PWM-out PMB for 5V power to servos

Servo 1 signal to M1 PMB
Servo 1 +/- to FMU-PWM-out PMB

Servo 2 signal to M2 PMB
Servo 2 +/- to FMU-PWM-out PMB

I have no more ideas for solutions….

Video to explain better!

Have you pressed the safety button? Is it armed? Is RC calibrated?

Yes of course :wink:

See the video link at end of my post.

Have you tried calibrating the ESC using QGC?

so i have new info´s. The receiver in the video ist the T-Motor T60A with default “low” timing. I use for test with another receiver the Hobbywing X-Rotor 40A, with intermediate timing (default). The throttle works now, with ECS signal to M4 on the PDB :joy:
Now what’s the problem with the T-Motor T60A (timings low/med/high). I habe change to med and also throttle functional.

Whats the solution with timings? What is need for px4 or what ist the problem with timing?!?

too happy… :smirk:

all timings testet, beep-beep-beep after ARMING; with the Hobbywing receiver turn off the beep, with ARMING.
But what the problem with the T-Motor receiver, the 400hz? The Hobbywing has up to 621hz.

ESC calibration in QGC was fine.

THE SOLUTION … more or less …

The manual of ECS say “beep…beep” = “throttle stick is not in lowest position”. But when i connect ESC signal over M4 on the PDB no error beep. Only connect over FMU-PWM-out from PMB, the ECS beep, also with SYS_USE_IO disabled.

I’m happy… :sweat_smile:

If you want to prevent it from beeping when disarmed you need to use one of the params to set the “disarmed” PWM value:

https://dev.px4.io/en/advanced/parameter_reference.html#PWM_AUX_DIS4 (or whatever channel), or
https://dev.px4.io/en/advanced/parameter_reference.html#PWM_MAIN_DIS4 (or whatever channel).

Good note, spares the nerves :wink:

1 Like