No optical flow data from PX4Flow with Pixhawk 4

No, it didn’t run out of the box for v1.12.3. The sensor alone via usb worked nicely…but no luck going through the pixhawk. Did you have more luck? or any advice?

I need to try this. I have one PX4Flow, let’s see,


Ok, can you set these params and tey again?


After a reboot:

SER_TEL4_BAUD : 115200

You must have your PX4 Flow messages coming. Just don forget that PX4Flow needs to be powered seperately before Pixhawk boots.

1 Like

Thx a lot for these hints & suggestions, I will try them hopefully next week.
I am a bit surprised that PX4Flow needs to be powered separately & before Pixhawk boots: I didn’t see that anywhere in the documentation…also all the guides/pictures just show one 4 or 6 pin cable connected between PX4Flow & pixhawk.

hello friend, how to power a pxflow board ?

Hello! I have a similar problem. I connect PX4Flow via I2C to pixhawk. In the pixhawk settings, I look for the SENS_EN_PX4FLOW parameter and set it to PX4Flow. Mavlink Inspector does not show optical flow data after reboot. In the console I write the command
“px4flow start -X -a 0x45” to which I get a response
“WARN [SPI_I2C] px4flow: no instance started (no device on bus?)”
I also tried to set up a connection through the firmware of the ardupilot (specified the parameter FLOW_TYPE = 1) and also do not get a response. And if PX4Flow is connected directly via USB, then I get the data. Please tell me what to do

Problem solved. The problem was in the wrong connection of wires via I2C.

1 Like

did u make it work on the board? I tried but I cannot change to position mode in the flight

hello, were you able to enable the parameter OPTICAL_FLOW_RAD??? could you please guide me through…even i tried updating QGC, yet the parameter is not shown in mavlink inspector.