Need Help : Pixhawk 2.4.8 no GPS

Dear all,
I using last Qgroundcontrol version and flash ver px4 is : 1.11.3
so FC don’t see GPS! mys GPS is RadioLink SE100.
I testing GPS with U-blox, It work!
I think GPS port was broken. So I trying change jack gps to Serial 4/5, Telem1, Telem2 and config it with GPS2, Telem1, Telem2. But FC not see GPS.
Please helpme to fix
Thanks
Reed.


NoGPS
ver

What lights are on your GPS? It should glow solid green for an accurate GPS. GPS may not receive very well.
Check out this document for led meanings
https://docs.px4.io/master/en/getting_started/led_meanings.html

Hello @ReedNoel,

I believe the solution to your issue will be found somewhere deep within the documentation. I have uploaded a picture of the Pixhawk 4 GPS module port pinout since I assume that is what you are using. If not then look for the pinout for your flight controller online.

I did not see the RadioLinkSE100 as a supported GPS module in the documentation here: GPS & Compass | PX4 User Guide
That doesn’t mean it won’t work, but the documentation provides a cautionary tale that the pins could be different thus results in an inability to get the correct signal with the provided cables.

The RadioLinkSE100 manual can be found here: Radiolink Electronic Limited
A connection to the Pixhawk 1 can be found in the manual but if you are using a newer Pixhawk with different GPS ports then knowing the SE100’s pins is crucial to success. A picture of the wires can be seen here

If the GPS is hooked up to the right pins and it still isn’t working then I would recommend changing the buad rate on the GPS. RadioLink has on their product page stating explicitly about the GPS: UART port with baud rate 9.6K. Pixhawk has the baud rate set to Auto in order to detect the various supported GPS modules. However, you are using one outside the supported versions so it may not be picking up the signal because it doesn’t know what speed it is occurring.

If you want to change the baud rate then you should venture here: Serial Port Configuration | PX4 User Guide
You will have to follow the steps and change the baud rate to 9600 but that may be the solution.

I hope you found this helpful. Let us know if it works or not.

Chris

Thanks @Soren, @merve
I set baudrate of 2 gps are 9600, a doing step by step.
And I install 2 GPS, 2 of them are u-blox. and setting GPS1 and Serial 4, But NO GPS.
before 3 year, I used Radio Link SE100, It worked perfect.
Please see video and picture and help me.
Thanks anh Best regard.
Reed.



3
4

Somebody help…me, I can’t takeoff…

1- Make sure the wires are connected to the connectors and the GPS module.
2- Go to the sensors section again and adjust the compass sensor and reboot.

Announce the result here

Hi @roomez
Thanks, But the same NO-GPS.
I trying many thing, but no see how is fix it
Rgs
Reed

@ksschwabe May you help me ?
Thanks
Reed

ok
please check connection GPS wire pinout with multimeter.
https://docs.px4.io/master/en/flight_controller/pixhawk.html#gps-port

GPS port

Pin Signal Volt
1 (red) VCC +5V
2 (blk) TX (OUT) +3.3V
3 (blk) RX (IN) +3.3V
4 (blk) CAN2 TX +3.3V
5 (blk) CAN2 RX +3.3V
6 (blk) GND GND

Dear @roomez
Thanks for your reply.
I measure, voltage are right: VCC : 4.8v, Tx andrx: 3.29v.
I test Serial 4/5 as telemetry port, it work so when I using this port for GPS second, QGC not see GPS.
Thanks
Note: If you have free time, help me ultraview, teamviewer to see parameter ara mistake
Reed.

send me your parameters (.param file)

Dear @roomez ,
I can’t attach file here!.
please see the link
https: //drive.google. com/file/d/ 1ROYRmqWKHujGlhHx_ZJ8rMR0Skf919OB/ view?usp=sharing
Thanks
Reed

The link does not work!

In this forum, I add some space, please delete ít
Thanks so much