Micrortps_client fails over UDP: could not set pthread name

I am running ros2 foxy, trying to do sitl simulation in Gazebo. I make the program with make px4_sitl_rtps gazebo, but when I run micrortps_client start -t UDP, i get the following:

INFO  [micrortps_client] UDP transport: ip address: 127.0.0.1; recv port: 2019; send port: 2020; sleep: 1ms                                                                                            
INFO  [micrortps_client] UDP transport: Trying to connect...
INFO  [micrortps_client] UDP transport: Connected to server!
ERROR [micrortps_client] Could not set pthread name (0)

I can’t find anything online related to this error. Please let me know if I need to clarify the issue further.

This is a minor problem that doesn’t stop the bridge of working. Have you checked if the bridge works?

Checking if the bridge works as in, calling the micrortps_agent?

In that case, when I run micrortps_agent -t UDP

my console is inundated with the message:

[ micrortps_agent ] Unexpected topic ID to publish

I think that means it’s not working?

It means that you are probably using an older version of PX4 (maybe a stable one) together with the more recent version of px4_ros_com or vice-versa. Currently you can only use master of one with the master of the other.